Please see our tutorial videos at
http://www.wildlifeacoustics.com/support/tutorial-videos/
Table of Contents

Kaleidoscope 4.1.0 Documentation

Overview ........................................................................................................................................ 4

Global Analysis Modes: Bats or Non-bats? ............................................................................ 4

Batch capabilities ...................................................................................................................... 4

Kaleidoscope Viewer ................................................................................................................. 5

File Conversion .............................................................................................................................. 6

File Types ................................................................................................................................... 6

Batch File Conversion ............................................................................................................... 7

Choose the input files you wish to convert: ........................................................................... 7

Choose the output formats you wish to convert to: ............................................................... 7

Caveats ....................................................................................................................................... 8

File Naming Conventions ......................................................................................................... 9

Filtering Noise Files (Bat Analysis Mode only) ...................................................................... 11

Extracting GPS Tracks ............................................................................................................... 12

Meta Data .................................................................................................................................... 13

Kaleidoscope Meta Data (Wildlife Acoustics Meta Data "WAMD" Format) ......................... 13

Mapping AnalookW Meta Data to Kaleidoscope ................................................................. 14

GUANO Metadata ..................................................................................................................... 15

Adding Field Notes to Output Files ....................................................................................... 17

Automatic Identification for Bats ............................................................................................. 18

Output Summary File (idsummary.csv) ................................................................................... 18

Output Identification File (id.csv) ............................................................................................ 19

Explaining Maximum Likelihood Estimators (MLE) and P-values used in Kaleidoscope

Classifiers ..................................................................................................................................... 24

Kaleidoscope Viewer ................................................................................................................... 26

The Waveform Plot ................................................................................................................. 26

The Spectrogram Plot ............................................................................................................... 26

Shared Waveform and Spectrogram Controls ...................................................................... 28

Spectral Analysis ....................................................................................................................... 28

Playback ................................................................................................................................. 30

Playback to a file ....................................................................................................................... 30

Copyright © 2017 Wildlife Acoustics, Inc. 2
Saving a screenshot ................................................................................................................. 30
Time Expansion ....................................................................................................................... 30
Automatic Identification and Cluster Assignment .............................................................. 30
File and Folder Navigation ..................................................................................................... 31
Meta Data ............................................................................................................................... 31
Results Table ........................................................................................................................ 32
Settings .................................................................................................................................. 33
Color Settings .......................................................................................................................... 33
FFT Settings ............................................................................................................................ 33
Keyboard Shortcuts ................................................................................................................ 34
Cluster Analysis ..................................................................................................................... 35
Clustering Modes .................................................................................................................... 35
Scan and Cluster Recordings ................................................................................................. 35
Re-scan recordings and edited cluster.csv ............................................................................. 35
Use existing .kcs file to sort new recordings ......................................................................... 36
Overview of the Clustering Algorithm .................................................................................. 36
  Signal Detection and Feature Extraction .............................................................................. 36
  Hidden Markov Model .......................................................................................................... 36
  Fisher Scores ........................................................................................................................ 36
  Clustering ............................................................................................................................. 37
  Pair-wise classifiers .............................................................................................................. 37
Clustering Parameters ......................................................................................................... 37
  Parameters in the Cluster Analysis tab ............................................................................... 37
Cluster Results Table ............................................................................................................ 38
Noise Analysis Module .......................................................................................................... 41
Noise Module Requirements ................................................................................................. 41
Supported Measurements ...................................................................................................... 41
Configuring the Noise Analysis Module .............................................................................. 42
Noise Analysis Module Outputs ............................................................................................ 43
Use of Meta Data .................................................................................................................... 44
Kaleidoscope Release Notes 4.3.1 .......................................................................................... 46
Overview

Kaleidoscope is a collection of tools for the efficient processing of acoustic and ultrasonic recordings. Some of these tools are licensed separately.

Mac OS X users should use "Control-Click" where these instructions refer to "Right-Click".

Kaleidoscope retains most of its settings and writes them to a file "kaleidoscope.ini" in the user's data directory (operating system specific). Before processing a batch of files, a copy of this file is written to the "settings.ini" in the output directory. You can load a settings file or restore default settings from the "File->Load Settings..." and "File->Set Defaults" menus.

Global Analysis Modes: Bats or Non-bats?

Kaleidoscope has several settings and parameters that are specific to past and present conventions for recording bats (e.g. time expansion and zero crossing) that are not suitable for the conventions used to analyze other kinds of audio recordings. The first time you launch this version of Kaleidoscope, or after setting defaults, you will be asked to choose either "Bat Analysis Mode" or "Non-bats Analysis Mode" as your preferred analysis mode. You can also change your preference at any time using the control at the top left of the control panel. Many of Kaleidoscope's features and settings are only available in one of these two modes. Controls for features that are not available for the selected mode are disabled and greyed out.

Batch capabilities

In a single batch operation, Kaleidoscope can perform several tasks in parallel:

- **Convert audio file formats**
  - .wac from Wildlife Acoustics compressed format
  - .wav from or to Waveform Audio File Format
  - .??# or .zc from or to AnaLookW zero crossing sequence file format (bats only)
  - Support for both time-expanded (bats only) and normal speed .wav files
  - Support for breaking large files into smaller pieces
  - Support for splitting multi-channel recordings into multiple single channel recordings (note Kaleidoscope only supports up to two channels at this time)

- **Add field notes and other fields** to meta data in output files and extract meta data from files into output meta.csv
- **Filter noise files** detects and removes or segregates files containing only noise (bats only)
- **Extract GPS metadata** from files to produce .csv or .kml
- **Automatic Identification for Bats** of files to species and generate files suitable for creating pivot table reports (bats only, requires Kaleidoscope Pro or region-specific classifier license).
- **Noise analysis** measures signal levels in recordings using third octave bands and various weighting standards (non-bats only, requires Kaleidoscope Pro or noise analysis license).
• **Cluster analysis** for detecting and sorting biological vocalizations in recordings into clusters by similarity and building customized classifiers (requires Kaleidoscope Pro license)

Kaleidoscope runs in parallel during batch processing by dividing work into multiple threads to take advantage of computers with multiple processing cores. By default, Kaleidoscope will try to maximize utilization by using a number of threads equal to the number of available cores, plus one. Memory usage will also grow proportionally with the number of threads utilized. You can adjust the number of threads used by Kaleidoscope by using the pull-down in the upper right corner of the control panel e.g. "Use 3/5 compute resources". This may be necessary on a machine with limited memory available or desirable if you want to perform other tasks while Kaleidoscope is running in the background.

**Kaleidoscope Viewer**

In addition, with **Kaleidoscope Viewer**, you can:

- View spectrograms by opening individual full spectrum or zero crossing files
- Take cursor measurements and view bat call parameters
- Analyze and export spectral data
- Add or edit meta data (e.g. field notes and manual classifications) to files
- Quickly review and manually verify automatic identifications
- Listen to or save .wav files applying bandpass filtering, speed and amplitude adjustments.
File Conversion

Kaleidoscope can convert a batch of input files recorded in a variety of input formats to output files in a variety of output formats. This feature is available at no charge.

File Types

.wac Wildlife Acoustics Compressed Format

The .wac or Wildlife Acoustics Audio Compression format is a legacy proprietary audio format produced by Song Meter and Echo Meter recorders. A .wac file may contain one or more channels (mono or stereo recordings), and these recordings may be either continuous or triggered. Triggered recordings are used for ultrasonic work (e.g. recording bats) where only periods of detected activity (a triggered event or "bat pass") are recorded. A triggered .wac file may contain several triggered events as they are detected independently on each channel. In addition to acoustic data, .wac files may contain GPS track information when created by GPS-enabled recorders.

.wav Waveform Audio File Format

The .wav format is a de facto standard developed by IBM and Microsoft for representing multi-channel audio recordings. There are several flavors of .wav file formats that may utilize different forms of audio compression and meta data. Kaleidoscope supports only uncompressed 8-bit and 16-bit Pulse Code Modulation (PCM) .wav files. Wildlife Acoustics has also defined a proprietary (WAMD) extension to the .wav file format to store metadata and also supports the (GUANO) meta data format.

Time Expanded Files:

In "Bat Analysis Mode", the .wav format described above may also represent time expanded recordings. Time expanded recordings are commonly used in ultrasonic work where the original recording is stretched through time by a constant factor effectively slowing it down such that ultrasonic signals are divided down into the audible range. This is accomplished by simply adjusting the sample rate of the recording. For example, if a recording is made at 384,000 samples per second, the sample rate in the file's metadata can be changed to 38,400 while keeping all the original audio samples. If we now play back this file at 38,400 samples per second, it will take ten times longer to play and the frequencies will have been divided down by a factor of ten times. Such a file would be said to have a time expansion factor of 10.

With Kaleidoscope, you can specify an explicit expansion factor for input files, or you can use the "Auto" setting. The "Auto" setting assumes these are ultrasonic recordings, and uses a time expansion factor of one for sample rates greater than 96,000. Otherwise, a time expansion factor of ten will be used, unless a different time expansion factor is explicitly defined in the source file meta data.
.??#, .zc AnalookW Zero Crossing Sequence File Format

The .??# format is a proprietary format used in legacy zero-crossing bat detectors developed in the early 1990s by Chris Corben for Titley Electronics. These are not "recordings" in the conventional sense in that the original analog signal was not digitized and saved like they are in .wac and .wav files. Instead, the time between a number (division ratio) of sequential zero crossings is stored in the file. The original signal cannot be reconstructed from this small amount of data. However, with sufficient signal-to-noise ratio, the dominant frequency sweep through time produced by the echolocation calls of bats can be represented. More recently, the .zc file extension is also used to represent these files.

Batch File Conversion

Choose the input files you wish to convert:

From the "Batch" tab on the Kaleidoscope control panel, set the "INPUTS" parameters found on the left hand side of the window:

1. Choose your "Input directory", a folder on your computer containing the input files you wish to convert. Remember you are choosing a directory, not a file. On some operating systems, files in a given directory will not be shown, or will be grayed out.
2. Check "Include subdirectories" if you want to convert files recursively in all the subfolders below the "Input directory" specified above. Otherwise only the files found in the "Input directory" will be converted and subfolders will be ignored.
3. Check "WAC files" if you want to convert from .wac files.
4. Check "WAV files" if you want to convert from .wav files. In "Bat Analysis Mode", you must also select the "Time expansion factor" used by the input files. A factor of "1" should be used for normal speed files. If the input .wav file was created by a time expansion bat detector, the time expansion factor should be set to the time expansion factor used to make the recording. The "Auto" setting can be used to automatically choose a time expansion factor of one for high-speed recordings (e.g. sample rates greater than 96 kHz) or ten for lower speed recordings (e.g. less than or equal to 96 kHz) unless an explicit time expansion factor can be found in the meta data.
5. In "Bat Analysis Mode", check "ZC files" if you want to convert from .??# and/or .zc files.
6. You can add comments and other textual information to the meta data in the output files by appending, prepending, or replacing any existing meta data. See Meta data for more information.

Choose the output formats you wish to convert to:

From the "Batch" tab on the Kaleidoscope control panel, set the "OUTPUTS" parameters found on the right hand side of the window:
1. Choose the output directory in which you want to write the output files. Note that this must not be under the input directory. If the input "Include subdirectories" is checked, output subfolders will be created mirroring the directory structure of the inputs.

2. You can optionally have Kaleidoscope arrange outputs into daily or nightly subfolders (if Kaleidoscope can determine the recording timestamp from the input filenames or metadata) by choosing "Daily" or "Nightly" for "Create subdirectories" Otherwise, you can specify "None".

3. If you would like Kaleidoscope to break up long files into multiple short files, you can specify a value for "Split to max duration", otherwise leave this field blank.

4. Check "WAV files" if you wish to convert to .wav files. Check "Split channels" if you would like to separate each channel of a multi-channel input file into individual single-channel output files. In "Bat Analysis Mode", if you want to output time expanded files, you can specify a time expansion factor. For normal time files, use a factor of "1".

5. In "Bat Analysis Mode", check "ZC files" if you wish to convert to .zc files. You can specify the "Division Ratio" to use. You can also check the "8.3 file names" to output files with the legacy 8.3 filename convention (note that 8.3 filename convention can only be performed if the input files have a compatible timestamp). Otherwise Kaleidoscope will use the suffix .00# or, if you check "Use .zc instead of .??#", Kaleidoscope will use the suffix .zc

Caveats

In "Bat Analysis Mode", there are a number of important caveats to keep in mind when converting files:

1. Converting from .??# or .zc zero crossing formats to .wav full spectrum formats is not possible to do accurately because zero crossing formats do not contain any amplitude or harmonic content information from the original recorded signal. Instead, Kaleidoscope uses sophisticated digital signal processing techniques to synthesize a full spectrum signal from the zero crossing data that simulates the frequency modulated signal through time, but with no harmonic structure and with uniform amplitude information.

2. Converting from .??# or .zc to .??# or .zc produces a copy of the original file and does not actually change the division ratio or split the recording into smaller pieces.

3. The .??# and .zc file format has a number of file size and duration limitations that are enforced. If converting from a longer .wav or .wac file, multiple .??# files may be produced to avoid exceeding these limits (15 second duration or 32KB filesize or 16K divided zero crossing points).

4. Converting from .wav or .wac full spectrum to .??# zero crossing uses digital signal processing controlled by additional parameters found in the "Signal Parameters" tab of the Kaleidoscope control panel. Zero crossing hardware technology has a disadvantage over full spectrum recording technology of approximately 20dB in signal-to-noise ratio (SNR) because zero crossing hardware must overcome noise in the entire frequency bandwidth of interest while Fourier analysis of full spectrum signals must only overcome noise in a narrow frequency bin. Kaleidoscope implements patented advanced signal processing algorithms for extracting zero crossing data from full spectrum recordings. These algorithms are enabled (by default, recommended) by checking the box "When
zero crossing for conversion or analysis, enhance with advanced signal processing" in the "Signal Parameters" tab of the Kaleidoscope control panel. When turned off, the full spectrum input is band-pass filtered according to the frequency range specified by the "Signal of interest" described in the "Signal Parameters" tab and the resulting signal is converted to zero crossing without further enhancement. When turned on, Kaleidoscope further enhances the signal with noise reduction and echo cancellation techniques prior to zero crossing, but also removes echoes and fragmented calls. The result is a cleaner filtered zero crossing output that may detect weak signals that would have been missed or fragmented using conventional zero crossing hardware. On the other hand, some weaker or fragmented pulses remaining may be discarded. We recommend leaving this feature turned on, especially when using our "Auto ID for Bats"

Running the batch

Press the "Process files" button to run your batch. A progress bar will display estimated time remaining.

Keep in mind that Kaleidoscope may be performing other tasks in parallel with file conversion such as filtering, GPS track extraction, automatic classification, noise analysis and cluster analysis. You should familiarize yourself with these features as they may affect the outputs.

File Naming Conventions

The Song Meter line of products use the following naming convention:

    Prefix_ YYYYMMDD_hhmms . extension

A "Prefix" may be optionally specified in the Song Meter configuration (typically to keep track of files from different Song Meters with different prefixes). If present, the prefix is prepended to the filename with an underscore character between the prefix and the year. The extension is either "wav" for a WAV file, "wac" for a WAC file, or "00#" or "zc" for a Zero crossing file.

On the Echo Meter EM3, the file name convention is slightly different to accommodate an additional optional tag character (represented by "T" below). This may be included if one of the tag buttons (e.g. A, B, C, or D) is pressed during recording, or the special "N" tag used to mark potential noise files. If no tag is present and the file is not a noise file, then the tag character is an underscore. The file name looks like this:

    Prefix_ T_YYYYMMDD_hhmms . extension

The output file name format will be in one of the following formats:

    Prefix_ YYYYMMDD_hhmms_mmm . extension
    Prefix_ T_YYYYMMDD_hhmms_mmm . extension
    Prefix_ C_YYYYMMDD_hhmms_mmm . extension

If an Echo Meter tag is specified, the second form is used with "T" representing the tag
If splitting channels from stereo to two mono channels, the third form is used with "C" representing the channel number (0 = left, 1 = right).

Otherwise the first form is used. In all these forms, an additional mmm is appended indicating the milliseconds offset.

When converting files that are not in the Song Meter filename format, the original filename is preserved and appended with _C_sssss_mmm . extension.
Filtering Noise Files (Bat Analysis Mode only)

During batch [file conversion](#), Kaleidoscope can analyze each output file looking for biological activity of interest and removing files containing only uninteresting signals such as ambient background noise, rain and wind, or unwanted biological signals such as insects when trying to record bats.

Kaleidoscope looks for echolocation pulses of smooth continuous narrowband frequency sweeps characteristic of bats.

On the "Signal Parameters" tab of the Kaleidoscope control panel, there are several parameters used to describe the signal of interest. As files are processed, Kaleidoscope decides if the file meets the criterion specified. If a file does not contain at least "Minimum number of pulses" that have frequencies and durations in the ranges specified, then the file is considered "noise".

On the "Batch" tab of the Kaleidoscope control panel under "OUTPUTS", there is a pull-down to control noise filtering:

1. **Disable noise filtering** disables filtering of noise files. All files are processed even if no pulses are detected.
2. **Delete noise files** deletes any output files that are considered noise.
3. **Move noise files to NOISE subfolder** moves any output files considered to be noise to a subfolder marked "NOISE" so the files can still be manually reviewed but are conveniently segregated from files more likely to contain good echolocation calls.

Useful tip: weak signals may cause a discontinuity in a detected syllable resulting in two or more smaller fragments. You may want to use smaller values for the minimum signal duration in order to consider these weaker signals as "interesting". Setting the minimum duration to 0ms will allow even the smallest pulses to be counted as long as they meet the frequency range requirements.
Extracting GPS Tracks

During batch file conversion, the GPS track can be extracted from meta data found in the input files. To enable this feature, you can go to the "Batch" tab of the Kaleidoscope control panel and choose the GPS processing mode:

Extract GPS Disabled

Disables extraction of GPS metadata.

Extract GPS to CSV

Extract GPS data found in the metadata of input files and create a "gps.csv" file in the output directory. Columns are created for DATE, TIME, LAT, LON, and NAME, where NAME is the filename of the corresponding output file or blank for waypoints. If waypoints are available (e.g. in a .WAC file), the frequency of waypoint extraction can be specified in seconds.

Extract GPS to KML

Extract GPS data found in the metadata of input files and create a "gps.km" file in the output directory. The KML file can be opened directly from Google Earth and have a placemark corresponding to each output file. If waypoints are available (e.g. in a .WAC file), the frequency of waypoint extraction can be specified in seconds and are represented as a path in the KML.
Meta Data

Meta data are bits of information embedded in an audio files that might be useful in the interpretation of the recordings. For example, meta data might describe the location, habitat, weather, and deployment details for a given recording session.

Kaleidoscope enables the use of meta data embedded in audio files. For .wav files, Wildlife Acoustics defines a proprietary extension in which to store meta data. For .??# and .zc files, there are a number of fields defined for this purpose. Additionally, Kaleidoscope also simultaneously supports the GUANO meta data format (see below) in .wav, .??# and .zc files.

Meta data can be viewed (and some fields can be edited) from the meta data control panel in Kaleidoscope Viewer. This panel can be toggled between hidden and shown with the button.

Kaleidoscope Meta Data (Wildlife Acoustics Meta Data "WAMD" Format)

Kaleidoscope makes use of the following meta data fields if available in the recording:

Voice note

An embedded audio notation such as those created by the Echo Meter Touch. The icon button will appear if a voice note is present, and clicking the button will play the voice note recording.

Prefix

The user-defined file prefix.

Model

The recorder model name.

Serial Number

The recorder serial number.

Firmware

The recorder firmware version.

Timestamp

The date and time a recording was made.
GPS Location

If a GPS receiver was attached to the recorder, the GPS coordinates corresponding to where the recording was made may be available.

Notes

Field notes created, edited and viewed by humans that could be used to describe the field and deployment conditions in great detail.

Auto Identification Results

The automatic identification made to species by Kaleidoscope's Auto ID for Bats

Manual Identification Results

The manually verified identification made to species by a human expert.

Microphone Sensitivity

Calibrated microphone sensitivities saved in the recorder and used by the noise analysis module

Mapping AnalookW Meta Data to Kaleidoscope

For .??# or .zc files manipulated by AnalookW software, there are several meta data fields mapped to and from Kaleidoscope meta data fields as follows:

<table>
<thead>
<tr>
<th>AnalookW Meta Data</th>
<th>Kaleidoscope Meta Data</th>
<th>Additional Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tape</td>
<td>Notes</td>
<td>A line in the Notes field that begins with &quot;Tape: &quot;</td>
</tr>
<tr>
<td>Loc</td>
<td>Notes</td>
<td>A line in the Notes field that begins with &quot;Location: &quot;</td>
</tr>
<tr>
<td>Spec</td>
<td>Notes</td>
<td>A line in the Notes field that begins with &quot;Spec: &quot;</td>
</tr>
<tr>
<td>Notes</td>
<td>Notes</td>
<td>Additional lines in the Notes field</td>
</tr>
<tr>
<td>Filetime</td>
<td>Timestamp</td>
<td></td>
</tr>
<tr>
<td>Lat, Lon</td>
<td>GPS Location</td>
<td></td>
</tr>
<tr>
<td>Species</td>
<td>Automatic Identification Results and Manual Identification Results</td>
<td>The &quot;Species&quot; field in AnalookW is formatted as &quot;AUTOID (KS AUTOID,STATS)&quot; or &quot;MANUALID !(KS AUTOID,STATS)&quot; where AUTOID is the automatic classification, MANUALID is the manually verified classification, and STATS are Kaleidoscope statistics. Note that older versions of Kaleidoscope used &quot;Kaleidoscope&quot; instead of &quot;KS&quot; as shown above. This was shortened to</td>
</tr>
</tbody>
</table>
allow for more available space in this field for other uses. At 4.3.1 and later, the statistics are replaced with alternate identifications.

GUANO Metadata

The Grand Unified Acoustic Notation Ontology for bats (GUANO) meta data format is a recent (2017) effort lead by David Riggs in collaboration with others to standardize meta data formatting in audio files for interoperability among and between different brands of detectors and analysis software. See https://guano-md.org for more details. As of Kaleidoscope version 4.3.0, GUANO is fully supported with a Kaleidoscope Pro license. GUANO will not be read or written without a Pro license.

Kaleidoscope attempts to maintain both WAMD and GUANO metadata as well as AnalookW metadata simultaneously while reconciling differences and merging information where possible.

GUANO meta data consists of key:value pairs of text. Some fields are standardized while others are vendor-specific. Kaleidoscope allows all arbitrary GUANO meta data to be read, edited, and written. Many standard fields and Wildlife Acoustics vendor specific fields are also used. The following table describes special GUANO fields:

<table>
<thead>
<tr>
<th>GUANO key</th>
<th>Kaleidoscope Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter HP</td>
<td>Kaleidoscope Viewer will fill in these fields when saving a .wav file with the bandpass filter enabled.</td>
</tr>
<tr>
<td>Filter LP</td>
<td></td>
</tr>
<tr>
<td>Firmware Version</td>
<td>Kaleidoscope will fill in the firmware version if known for Wildlife Acoustics recorders.</td>
</tr>
<tr>
<td>Length</td>
<td>Kaleidoscope will set the duration of the file (in seconds)</td>
</tr>
<tr>
<td>Loc Position</td>
<td>The GPS coordinates in WGS84 latitude and longitude.</td>
</tr>
<tr>
<td>Make</td>
<td>Kaleidoscope will fill in &quot;Wildlife Acoustics&quot; for Wildlife Acoustics recorders.</td>
</tr>
<tr>
<td>Model</td>
<td>Kaleidoscope will fill in the model of Wildlife Acoustics recorder if known.</td>
</tr>
<tr>
<td>Note</td>
<td>The note field for user notes. The note field will be displayed in the notes area of the viewer tab or indicated in the notes section of the &quot;Batch&quot; control panel instead of being displayed with the GUANO &quot;Note&quot; tag.</td>
</tr>
<tr>
<td>Samplerate</td>
<td>Kaleidoscope will fill in the sample rate as adjusted by the time expansion factor.</td>
</tr>
<tr>
<td>Metadata Key</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Serial</td>
<td>Kaleidoscope will fill in the serial number of the Wildlife Acoustics recorder if known.</td>
</tr>
<tr>
<td>Species Auto ID</td>
<td>The species assignment made by classifiers.</td>
</tr>
<tr>
<td>Species Manual ID</td>
<td>The species assignment made by humans.</td>
</tr>
<tr>
<td>TE</td>
<td>The time expansion factor.</td>
</tr>
<tr>
<td>Temperature Int</td>
<td>The internal temperature.</td>
</tr>
<tr>
<td>Timestamp</td>
<td>The file timestamp.</td>
</tr>
<tr>
<td>Original Filename</td>
<td>The original filename, at least when GUANO metadata was first applied.</td>
</tr>
<tr>
<td>Hardware Version</td>
<td>These Standard (and user or vendor defined) GUANO keys are not interpreted or generated by Kaleidoscope, but these and any vendor-specific or user-specific keys can be read, displayed, edited, and written by Kaleidoscope.</td>
</tr>
<tr>
<td>Humidity</td>
<td></td>
</tr>
<tr>
<td>Loc Accuracy</td>
<td></td>
</tr>
<tr>
<td>Loc Elevation</td>
<td></td>
</tr>
<tr>
<td>Tags</td>
<td></td>
</tr>
<tr>
<td>Temperature Ext</td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>arbitrary user defined tags</td>
</tr>
<tr>
<td>vendor namespace</td>
<td>arbitrary vendor defined tags</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Kaleidoscope</td>
</tr>
<tr>
<td>WA</td>
<td>Song Meter</td>
</tr>
</tbody>
</table>

Arbitrary GUANO metadata may be added to output files in batch mode by adding the following line to the notes field of the inputs of the "Batch" on the Kaleidoscope control panel followed by one or more lines consisting of arbitrary GUANO key:value pairs.
GUANO|Version:1.0
some tag:some value
another tag:another value
...

GUANO metadata can be viewed in the viewer, and it appears in the metadata panel "Notes" field as above e.g. beginning with a line containing "GUANO|Version 1.0". Again, GUANO metadata can be edited or added and saved back out. Note that you have to hit the "Enter" key or change a manual identification in order for the viewer to write out the file to update the metadata.

Adding Field Notes to Output Files

During batch file conversion, Kaleidoscope can replace, append, or prepend field notes to the meta data in output files. On the "Batch" tab of the Kaleidoscope control panel at the bottom of the "INPUTS" section on the left, you can select from among "Append notes to output meta data", "Prepend notes to output meta data" or "Replace notes in output meta data" and optionally type field notes into the text box below this choice. When you run the batch job, any notes provided will be added to any existing notes (depending on the choice specified) and written to the output files. Note that the original input files are not modified during batch processing. When outputting to .??# or .zc files, lines beginning with "Tape: ", "Location: " and "Spec: " are treated specially with the remainder of the line written to and replacing the corresponding AnalookW fields.

GUANO meta data may also be written to the output files by adding the line "GUANO|Version:1.0" at the end of any field notes followed by one or more key:value pairs. The GUANO Note field is excluded (use the preceding notes area).
Automatic Identification for Bats

NOTICE: Automatic identification is not perfect and will result in false positive and false negative errors. Never rely solely on the output of this software to make land management decisions. The automatic identification is intended only as a suggestion to facilitate analysis, not to replace human expert vetting of calls.

You must have a Kaleidoscope Pro license or region-specific classifier license to use the automatic identification feature. Wildlife Acoustics is building classifiers capable of fast and accurate identification to species. At this time, classifiers are offered for bats of North America, South and Central America, and Europe. Not all species are covered, and while our accuracy rates are impressive given the technical challenge, you should not rely solely on automatic classification results to draw conclusions. Our objective is to give you a tool to efficiently analyze a large quantity of data in a short period of time. Wildlife Acoustics hopes to continue expanding classification coverage to include other animals and geographic regions and to improve accuracy.

During batch file conversion, Kaleidoscope can apply classifiers to attempt automatic species identification at the output file level. In fact, it is not necessary to specify any output files in the batch process, but it is recommended to do so for efficient manual review and use of metadata.

To enable automatic classification, go to the "Auto ID for Bats" tab on the Kaleidoscope control panel, choose your classifier and desired sensitivity level. For best results, choose only those species you expect to find during your deployment.

More information about individual classifiers can be found by clicking on the "About" button shown when you select a classifier.

At the end of batch processing, an "idsummary.csv" and an "id.csv" file will be created at the top of the output directory. A results window containing some of the "id.csv" columns and the Kaleidoscope Viewer will be launched automatically so you can quickly review and update the auto classification results. The spreadsheet table can be saved after editing with "File->Save" or "File->Save As..". You can also re-open this view with Kaleidoscope Viewer from the Kaleidoscope control panel with "File->Load results..." to continue work where you left off.

Output Summary File (idsummary.csv)

The "idsummary.csv" file contains an overall summary of the batch classification. At a high level, this file is organized into rows representing output folders (from the input directory hierarchy) and columns representing species-specific data. More specifically, the first N columns represent the output directory structure hierarchy, where N is the maximum folder depth encountered. For example, if the input folder contained three subfolders A, B, and C, and each of these contained an additional three subfolders X, Y, and Z, we would have a total of 13 possible folder locations. This includes the root of the folder hierarchy, each of the three top level folders, and 9 additional subfolders including A/X, A/Y, A/Z, B/X, B/Y, B/Z, C/X, C/Y and C/Z. The
maximum folder depth in this example is two, so the first column represents the first level subdirectories and the second column represents the second level subdirectories. Asterisks are used to denote all the subfolders at a given level. So in this example, we would have the following rows and the first two columns:

<table>
<thead>
<tr>
<th>Column 1</th>
<th>Column 2</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>*</td>
<td>Represents overall totals</td>
</tr>
<tr>
<td>A</td>
<td>*</td>
<td>Represents totals for folder A and all its subfolders</td>
</tr>
<tr>
<td>A</td>
<td>X</td>
<td>Represents totals for files in A/X</td>
</tr>
<tr>
<td>A</td>
<td>Y</td>
<td>Represents totals for files in A/Y</td>
</tr>
<tr>
<td>A</td>
<td>Z</td>
<td>Represents totals for files in A/Z</td>
</tr>
<tr>
<td>B</td>
<td>*</td>
<td>Represents totals for folder B and all its subfolders</td>
</tr>
<tr>
<td>B</td>
<td>X</td>
<td>Represents totals for files in B/X</td>
</tr>
<tr>
<td>B</td>
<td>Y</td>
<td>Represents totals for files in B/Y</td>
</tr>
<tr>
<td>B</td>
<td>Z</td>
<td>Represents totals for files in B/Z</td>
</tr>
<tr>
<td>C</td>
<td>*</td>
<td>Represents totals for folder C and all its subfolders</td>
</tr>
<tr>
<td>C</td>
<td>X</td>
<td>Represents totals for files in C/X</td>
</tr>
<tr>
<td>C</td>
<td>Y</td>
<td>Represents totals for files in C/Y</td>
</tr>
<tr>
<td>C</td>
<td>Z</td>
<td>Represents totals for files in C/Z</td>
</tr>
</tbody>
</table>

For each species classifier enabled, there is an additional column indicating the number of files found matching the species. There is also a column for "NoID", meaning files that the classifier chose not to classify, and a column for "NOISE", meaning files that were unlikely to be bats. After these columns there is another set of columns for each species detected indicating the calculated presence [P-values based on a Maximum Likelihood Estimator](https://www.wildlifeacoustics.com).

## Output Identification File (id.csv)

The "id.csv" file has a row for each output file (excluding "noise" files but including "no identification" files). The columns are as follows:

**FOLDER**

Directory path to the input file relative to the input root

**IN FILE**

Input file name

**CHANNEL**
Channel number from the input file (0=left, 1=right)

OFFSET

Offset in seconds into the input file where output begins

DURATION

Duration in seconds of the output file

OUT FILE

Name of the output file, excluding file type extension.

DATE

Date in form YYYY-MM-DD of the recording

TIME

Time in form of hh:mm:ss of the recording

HOUR

Hour of the recording (0-23) for convenient pivot tables by hour

DATE-12

Date 12 hours prior to date of recording (e.g. for night vs. day) in the form YYYY-MM-DD

TIME-12

Time 12 hours prior to time of recording (e.g. for night vs. day) in the form hh:mm:ss

HOUR-12

Hour 12 hours prior to time of recording (e.g. for night vs. day)

AUTO ID

Automatic classification result

PULSES

Number of pulses detected in the file that were identified to species
MATCHING

Number of pulses matching the auto classification result

MATCH RATIO

The ratio of MATCHING over PULSES

MARGIN

Classification margin - this is an uncalibrated confidence score and should not be subject to much interpretation other than that within a given species, higher values are more confident than lower values.

ALTERNATES

In addition to the species identification, this field lists zero or more alternate species identifications separated by semicolons based on other pulse-level classifications detected in the file ranked from highest probability to lowest probability. This might suggest an alternate identification or multiple bats present.

N

Total number of pulses detected. This is used to derive average values for the following 12 parameters...

Fc

Average characteristic frequency (kHz) - the "body" of the call is the portion of the call consisting of the flattest slope where the characteristic frequency is typically the frequency at the latest part of the call body.

Sc

Average characteristic slope (Octaves per Second) - this is the slope of the body of the call. Positive values correspond to decreasing frequency while negative values correspond to increasing frequency.

Dur

Average duration (ms) - this is the duration of the call

Fmax

Average maximum frequency (kHz) - the maximum frequency detected in the call
Fmin

Average minimum frequency (kHz) - the minimum frequency detected in the call

Fmean

Average mean frequency (kHz) - the time-weighted mean frequency of the call.

TBC

Average time between calls (ms) - if "N" above is greater than one, this is the average period of the calls from the start of one call to the start of the next.

Fk

Average frequency of the knee (kHz) - the frequency at the beginning of the call body

Tk

Average time to the knee (ms) - the time from the beginning of the call to the beginning of the call body

S1

Average initial slope (octaves per second) - the initial slope of the call.

Tc

Average time to the characteristic (ms) - the time from the beginning of the call to the end of the call body

Qual

Average call quality (%) - a measure of the smoothness of the call where smaller values indicate a smoother call

FILES

The number 1, indicating one file, as a convenience for pivot tables by file count

MANUAL ID

Manual identification (this field populated during review with Kaleidoscope Viewer)
Note that this .csv file format is designed for easy import into spreadsheet software to create pivot tables. You can for example create pivot tables to summarize species-specific activity by site, by day, by night, or by hour.
Explaining Maximum Likelihood Estimators (MLE) and P-values used in Kaleidoscope Classifiers

The U.S. Fish and Wildlife Service Indiana Bat Summer Survey Guidance:


describes the use of approved software programs. As part of their software testing criteria:

"As species identifications are never perfect, all analysis programs must utilize a maximum-likelihood estimator approach to determine species presence at the site rather than relying on a single sequence. Post-hoc maximum-likelihood estimator p-values will be used to determine acceptance thresholds for final identification determination."

The maximum-likelihood estimator used by Kaleidoscope Pro is based on a 2002 paper by Britzke, Murray, Heywood, and Robbins "Acoustic Identification"


The method described takes two inputs. First, there are the classification results e.g. how many detections of each bat did the classifier find. Second, there is the confusion matrix representing the known error rates across all the classifiers. For example, 70% of MYLU calls are correctly classified as MYLU while 3% of MYLU calls are misclassified as MYSO, etc. The maximum likelihood estimator determines what the most likely distribution of different species are that would result in the observed classifications given the classifier error rate. Then, to calculate P-values, a given species is clamped as absent and the most likely distribution is recalculated. The ratio of the clamped likelihood divided by the original likelihood is the P-value.

In layman's terms, if we run an automated classifier on a data set, we will end up with a number of classifications for each species found in the data. From this, we want to determine the likelihood of presence or absence by calculating the P-value corresponding to the null hypothesis of absence. A low (near zero) p-value would therefore suggest presence.

For example, suppose we have a classification result with 70 MYLU detections and 3 MYSO detections. Given the error rate between MYLU and MYSO, the 3 MYSO detections are easily explained away as false positives from actual MYLU calls, so the P-value for MYSO in this case would be expected to be very high (unlikely present). On the other hand, if we have 70 MYLU detections and 20 MYSO detections, it is harder to explain away all 20 MYSO detections as false positives from actual MYLU calls, so the P-value for MYSO in this case would be expected to be very low (likely present).
There are some important caveats:

First, remember that an important input to the calculation is the known confusion matrix of the classifier. Unfortunately, there is no such thing. The error rates of a bat classifier will vary from one site to the next, because the bats will produce different calls in different habitats with different levels of clutter. In a high clutter environment, for example, you might expect to see a higher error rate than in a low clutter environment. It is also exceedingly difficult to measure the error rate without significant independently collected and verified data. For Kaleidoscope, we split our data in half using one half to train our classifiers and the other half to measure the error rates. This is a as good an estimate of the average confusion matrix that we can measure. But, it is not going to be the actual confusion matrix for any particular deployment. Therefore, the P-value calculations can't be determined exactly. They are only estimates.

Second, remember that while the P-value is perhaps the best statistical tool we have to work with, it is not perfect. A high P-value is not proof of absence. It simply means that there is not sufficient statistical evidence of presence. And a low P-value is not proof of presence, it simply means that the null hypothesis of absence cannot be explained by the data. A low P-value might suggest that an alternate hypothesis is more likely. That could be presence. But it could also be that the classification error matrix was not a good fit for the data.

MLE P-values are a convenient way to aggregate a lot of data and provide a useful statistic to estimate presence or absence of species. But, it is an imperfect statistic and should not be relied upon without some other means of verification of presence or likely absence.
Kaleidoscope Viewer

Kaleidoscope Viewer is a spectrogram viewer capable of opening .wac, .wav, and .??#/.zc files. It can also be used to view and edit meta data and quickly review automatic identification and clustering results.

On some operating systems, you can launch the Kaleidoscope Viewer by double clicking on a recording file icon.

You can also open a file in the Kaleidoscope Viewer from the Kaleidoscope control panel by using the "File->Open" menu. The Kaleidoscope Viewer is also launched automatically after batch processing with automatic classification or cluster analysis.

The Waveform Plot

The plot on the top is an oscillogram of the audio signal and represents amplitude on the vertical axis and time on the horizontal axis. Note that this plot is only available for full spectrum (e.g. .wav and .wac files) and would appear blank for zero crossing (e.g. .??# and .zc files) because zero crossing files do not contain any amplitude information.

Pressing the / button toggles between linear and log scales. The and buttons located to the right of the plot can be used to zoom in and zoom out of the vertical amplitude axis, and a vertical scroll bar can be used to scroll in the vertical direction.

Moving the mouse over the waveform plot shows a cursor and displays the time position in seconds and the amplitude value in either a linear or log (dB) scale. Moving the cursor while holding the left button down lets you create a selection box. The boundaries and deltas of the selection box are displayed in the status bar at the bottom of the Kaleidoscope Viewer window. The selection box can be cleared with a left click of the mouse.

If you right-click inside the selection box, a pop-up menu will appear offering you additional actions you can take on the selection. At this time, the only action supported is "Zoom to fit" which will expand the selection to fit the available window area.

Up to two horizontal reference lines can be set with a right-click of the mouse. The reference lines can be cleared with a double right-click.

Note that the brightness slider described below for the spectrogram plot adds or subtracts gain from the dB scale of the waveform plot.

The Spectrogram Plot

The plot below the waveform plot described above is the spectrogram plot and represents frequency on the vertical axis and time on the horizontal axis.
For full spectrum recordings (e.g. *.wav and *.wac files), the color intensity corresponds to the power level of the signal at a given frequency and at a given point in time. The brightness slider indicated by 🔄 / 🤓 can be used to decrease or increase the signal power color on a dB scale from -96dB to +96dB. This also affects the levels displayed on the waveform plot. The contrast slider indicated by 🔄 / 🍊 can be used to decrease or increase the dynamic range represented by the color gradient on a dB scale from -96dB to 0dB.

For zero crossing recordings (e.g. *.??# or *.zc files), dots representing a sequence of zero crossing points are shown. If shown with analysis (see below), the "body" of the call is highlighted in purple. This represents the flattest part of the call with constant slope terminating with the characteristic frequency and beginning with the "knee".

Kaleidoscope can convert full spectrum data to zero crossing data, and will show zero crossing dots superimposed on top of the color spectrogram plot. In Bat Analysis Mode, the dots represent literal zero crossings from the signal using either a simple bandpass filter or more advanced signal processing as described under caveats in File Conversion. In Non-bat Analysis Mode, the dots are synthesized by tracing the peak signal of syllables through time as a visual aid to the underlying signal detection algorithms. The 🔄 / 🍊 button toggles display of zero crossing dots between on with analysis, on without analysis, and off while the 🔄 / 🍊 button toggles display of full spectrum data on and off.

To the right of the spectrogram plot, the 📈 and 📈 buttons can be used to zoom in and out of the vertical frequency axis and a vertical scroll bar can be used to scroll in the vertical direction. The 📈 button toggles to a "zoom to fit" mode which will fit the vertical scale to the nyquist frequency.

Moving the mouse over the spectrogram plot shows a cursor and displays the time position in seconds, the frequency in Hz, and (for full spectrum recordings) the amplitude value in dB. Moving the cursor while holding the left button down lets you create a selection box. The boundaries and deltas of the selection box are displayed in the status bar at the bottom of the Kaleidoscope Viewer window. The selection box can be cleared with a left click of the mouse.

If you right-click inside the selection box, a pop-up menu will appear offering you additional actions you can take on the selection. At this time, the only action supported is "Zoom to fit" which will expand the selection to fit the available window area. For zero crossing files, you can also choose "Turn off dots". This will mark any selected zero crossing dots as "off" meaning they will be hidden from view and analysis. The Zero Crossing file is then updated with these changes. These hidden "off dots" can be displayed using the "Show/Hide off dots" control in the "FFT Settings" menu. To restore "off dots" so they are turned back on, first select "Show off dots" from the "FFT Settings" menu. Next select an area of the spectrogram that does not contain any dots. Then right-click and choose "Turn off dots". Since no dots are selected, no dots are hidden, but the file is re-saved with the now visible dots.

Up to two horizontal reference lines can be set with a right-click of the mouse. The reference lines can be cleared with a double right-click.
For Kaleidoscope Pro users, if you have a Bat Auto ID classifier installed, you can toggle on and off a visualization of our training data reference call clusters for comparing with your recordings with control-left-click. When turned on, blueish shapes of calls are superimposed on top of the spectrogram using the current frequency and time scales. The calls can be scrolled left and right by holding the control button while dragging the mouse left or right across the spectrogram or by using the left and right arrow keys. During training, we cluster together similar calls from the training set. The visualization represents a histogram of calls as if we layered all of the cluster members on top of each other. The yellow areas represent the path where most of the calls line up, and the blue region around them represent the variation of calls represented.

You can also open a blank window to look at just the reference call clusters with "Open Reference" from the menu.

**Shared Waveform and Spectrogram Controls**

The waveform and spectrogram plots share a number of controls. Just below the spectrogram plot, the \[ \text{放大} \] and \[ \text{缩小} \] buttons can be used to zoom both plots in and out on the horizontal (time) axis. The zoom levels for compressed and expanded views are separated so you can easily toggle between compressed and expanded views using preferred zoom levels for each mode. The \[ \text{放大} \] button toggles a "zoom to fit" mode which will fit the horizontal scale to the entire recording duration. Click again to restore the original zoom level. A scroll bar lets you scroll through time. The \[ \text{反向} \] / \[ \text{正常} \] button toggles inverse video mode. And the \[ \text{压缩} \] / \[ \text{正常} \] button toggles between compressed time and normal time views. Note that the compressed time view is based on Kaleidoscope's zero crossing conversion. If no zero crossing signals meeting the filter criteria are met, the compressed view will look blank.

You can left click and drag a region on the spectrogram frequency axis ruler to the left of the spectrogram plot to establish a bandpass filter, and the waveform plot is updated with the filter applied. The filter can be cleared with a left-click on the frequency ruler.

**Spectral Analysis**

The \[ \text{展开} \] button pops up an analysis window. This shows a spectral plot with frequency on the vertical axis and dB level on the horizontal axis. If a region of the spectrogram is selected with a box, the spectral plot shows data corresponding to the contents of the box. Otherwise, the spectral plot shows data for the time period displayed on the spectrogram (or fragmented periods in compressed mode).

The frequency axis follows the displayed spectrogram frequency axis, so you can zoom in and out of the frequency axis by using the zoom and scroll controls on the spectrogram display. The dB axis is normalized with the selected peak at 0dB and dynamic range follows the viewer contrast control.
A red line represents the power spectrum of the full spectrum signal. A dotted black and white line represents a weighted zero crossing histogram representing how long the zero crossing signal spends in a given frequency.

The following statistics are also calculated and displayed:

Tstart
Time offset to beginning of the selection being analyzed

Tend
Time offset at the end of the selection being analyzed

Fstart
Start frequency of the selection being analyzed

Fend
End frequency of the selection being analyzed

dBmin
Minimum power level of selection in dB relative to full scale

dBmax
Maximum power level of selection in dB relative to full scale

dBmean
Mean power level of selection in dB relative to full scale

Fpmin (full spectrum)
Estimate of minimum signal frequency. This is determined by following the peak frequency down to the noise floor.

Fpmax (full spectrum)
Estimate of the maximum signal frequency. This is determined by following the peak frequency up to the noise floor.

Fpmean (full spectrum)
This is the power-weighted mean frequency of the spectrum

Fppeak (full spectrum)
This is the peak frequency of the spectrum

N (zero crossing)
This is the number of bat echolocation pulses included in the analysis

Dur (zero crossing)
Average duration of echolocation pulses

TBC (zero crossing)
Average time between calls from the start of one call to the start of the next

Fmax (zero crossing)
Average maximum frequency of echolocation pulses

Fmin (zero crossing)
Average minimum frequency of echolocation pulses

Fmean (zero crossing)
Time weighted average frequency of echolocation pulses

Fc (zero crossing)
Average characteristic frequency of echolocation pulses. This is the point in a call at the end of the body of the call defined as the flattest part (lowest absolute slope) of the call.

Tc (zero crossing)
Average time offset from the beginning of the call to Fc.

Sc (zero crossing)
Average characteristic slope (slope of the body of the call) of echolocation pulses in octaves per second.

Fk (zero crossing)
Average knee frequency of echolocation pulses. This is at the beginning of the call body

Tk (zero crossing)
Average time offset from the beginning of the call to Fk.

S1 (zero crossing)
Average initial slope of echolocation pulses in octaves per second.

You can right-click and copy either the raw spectral data (minimum, mean, maximum and cumulative power density by FFT frequency bin in dBfs), full spectrum or zero crossing measurements in order to paste them into another application.

**Playback**

The \( \text{Play/Stop} \) buttons are used to play full spectrum data on your computer speakers. To the right of the play/stop button is the playback speed control. The playback can be at "Normal" speed or fast or slow by factors of 8, 10, 16, or 20 times. If a region is selected, the region is played. Otherwise the area shown on the screen is played. If a bandpass filter is turned on, it is applied. Finally, the brightness slider adjusts the volume of the playback. No sound is presently produced for zero crossing recordings but we may change this at a later date.

**Playback to a file**

You can use "File"->"Save samples..." to save the samples that would be played above to a .wav file applying the same bandpass filtering, volume and speed adjustments.

**Saving a screenshot**

You can use "File"->"Save screen..." to save the waveform and spectrogram view as a .jpg file.

**Time Expansion**

In Bat Analysis Mode, the time expansion factor can be used to specify if the file open in the viewer is time expanded. The "TE Auto" choice will automatically determine the time expansion factor from meta data first, or the sample rate second.

**Automatic Identification and Cluster Assignment**

In Bat Analysis Mode, if Bat Auto ID is enabled from the Kaleidoscope control panel, the pulse-by-pulse classification result will be shown at the top of the spectrogram plot indicating the species and cluster number associated with the classification. When all of the pulses in the file
have been classified, the pass-level analysis is performed. If a final identification is determined, the matching pulse-by-pulse values will be shown as bright while other values will remain grayed out. The final identification is also loaded into the identification button label in the meta data panel (see below).

In Non-bat Analysis mode, if Cluster Analysis is enabled from the Kaleidoscope control panel, the detected vocalizations are labeled with their cluster assignments in bright white.

You can toggle between enabling and disabling automatic identification or clustering with the \[I/\square\] button.

**File and Folder Navigation**

The title bar at the top of the Kaleidoscope Viewer window displays the folder name containing the current file and the current file name. For \[.wac\] files, it also displays the current trigger number out of how many triggers e.g. "(1 of 3)" indicates the first trigger out of three triggers in the file. The \[\leftarrow\] and \[\rightarrow\] buttons will change the view to the previous or next file in the folder respectively. The \[\uparrow\] and \[\downarrow\] buttons will change the view to the last file of the previous folder or the first file of the next folder respectively. For \[.wac\] files, the \[\uparrow\] and \[\downarrow\] buttons will change the view to the previous trigger or the next trigger in the file.

Note that for large files, Kaleidoscope may break the file into smaller more manageable pieces to conserve memory. In this case, the file looks like it contains two or more triggers and you can advance to the next part of the file with the next trigger button.

When the Kaleidoscope Viewer is linked to a results table (see below), the previous/next file and folder buttons are replaced with \[\leftarrow\] and \[\rightarrow\] and are used to go to the previous and next file or folder in the results table instead (where folder corresponds to the most recently sorted row of the table)

**Meta Data**

The \[\square\] button toggles between showing and hiding the meta data panel below at the bottom of the Kaleidoscope Viewer window. This panel displays meta data contained in the file such as timestamps and GPS coordinates. An editable field contains field notes and GUANO meta data if present. The GUANO meta data starts with "GUANO|Version:1.0" followed by lines consisting of key/value pairs. The values can be edited and new fields can be added. Note that the actual GUANO Note field is displayed in the note rather than as part of the GUANO metadata. Another editable field contains the manual identification. Below this field is a button that is populated with the results of automatic identification.

At the bottom of the Meta Data panel are 24 user-defined buttons used to assign manual identifications to the meta data. In Bat Analysis Mode, the button labels can be pre-loaded from the Bat Auto ID classifiers from the "File->Load labels" Kaleidoscope Viewer menu. The
buttons can be customized by right-clicking inside the button and typing in a new label. Left clicking a button loads the customized label value into the manual identification field.

There are thus three ways to assign a manual identification to the meta data. First, you can simply type an identification into the identification field and press return. Second, you can press the automatic identification button located below this field which is prepopulated with an automatic identification if determined. Third, you can press one of the user-defined buttons (or a corresponding shortcut key). If the "Auto next file" checkbox is checked, the or next file button is automatically activated after the manual identification has been set. In this way, you can quickly review and assign identifications to files.

To rename a file, push the "Rename" button. This will pop-up a window in which the filename can be edited.

To move a file to the noise folder and automatically go to the next file, press the "Noise" button.

**Results Table**

In Bat Analysis Mode, a results table can be loaded from the "id.csv" file created after a batch run with Auto ID for Bats enabled. In Non-bat Analysis Mode, a results table can be loaded from the "cluster.csv" file created after a batch run with "Cluster Analysis" enabled. In either mode, a results table can also be loaded from the "meta.csv" file created after a batch run on input files containing meta data. See [Auto ID for Bats](#), [Cluster Analysis](#), and [Meta Data](#) for more information.

The results table is automatically loaded after a batch run with Auto ID for Bats or Cluster Analysis enabled. The table can also be manually loaded from the "File->Load Results..." menu on the Kaleidoscope control panel. This causes a Kaleidoscope Results window and a Kaleidoscope Viewer window to appear and these two windows are linked together. The results window is a spreadsheet view into the underlying .csv file and shows a subset of available columns with a row for each output.

The displayed columns can be selected and re-ordered by using the "File->Edit columns..." menu of the results window. Note that most (but not all) columns are available for display.

Rows can be sorted by clicking on column headers. Clicking on a column header again will reverse the sort order. You can sort by multiple columns e.g. click on one column to sort on a first column, then click on a second column header to sort on the second column. In this case, all the matching second column rows will be together and sorted in the order of the first column.

Clicking on a row causes the linked viewer window to open and display the corresponding file. In the case of cluster analysis, only a portion of the file is loaded according to the offset and duration columns (padded by the maximum inter-syllable gap on either side).

From the "File" menu, you can bulk ID all matching auto ID or cluster membership results or selected rows to a value you specify.
The and buttons in the viewer will advance the linked results window to the previous or next row and open the corresponding file. If a manual identification is updated or the file is renamed in the viewer, the corresponding entry in the results table is also updated. In this way the files can be quickly reviewed with manual classifications added and the spreadsheet is updated at the same time. When finished, you can save the spreadsheet with the "File->Save" or "File->Save as..." menu on the results window. The resulting .csv file can then be opened in spreadsheet software and pivot tables can be easily created to summarize results.

**Settings**

The Kaleidoscope Viewer inherits many of its settings from the Kaleidoscope control panel at the time the Viewer window is opened. This includes the output time expansion factor (used to determine the correct sample rate with the assumption that you are opening output files and not input files), as well as filtering and classification parameters. From the Kaleidoscope Viewer window, you can reopen the Kaleidoscope control panel by using the "File->Control Panel" menu. To reload these settings into the viewer, use the "File->Reload" menu. This will apply the new settings to the viewer window and reopen the currently displayed file.

In Bat Analysis Mode, as a convenience, the time expansion factor is also controlled by a choice box so you can conveniently set the correct time expansion factor. This is critical for auto id. Make sure the vertical frequency axis represents the true frequencies of the bats, and not divided down (or up) by time expansion.

**Color Settings**

The "File>Color settings..." menu lets you customize the your color preferences. There are two full sets of colors you can set, one for "normal" mode and one for "inverse mode" which is toggled with the button. In normal mode, all text will be white so you should choose a darker color pallette. In inverse mode, all text will be black so you should choose a lighter color pallette.

For the spectrogram plot, you can choose the colors representing the maximum power ("High") and minimum power ("Low"). If both colors are not greyscale, you can specify the direction of changing hue from the high to low color in either Red-Yellow-Green-Cyan-Blue-Magenta ("RYGCBM") order or in Red-Magenta-Blue-Cyan-Green-Yellow ("RMBCGY") order. For the waveform plot, you can choose the foreground and background colors. For the zero crossing dots, you can specify normal dots and dots corresponding to the analyzed body of the call. And finally the cluster reference plots can be configured in the same way as the spectrogram with a high color, low color, and hue direction.

**FFT Settings**

The "File->FFT Settings..." menu can be used to change internal parameters. The FFT Size is the order of the Fast Fourier Transform (default 128). The Window Size is the step size and would be one half of the FFT Size (recommended) for a 50% overlap. The Max Cache Size is how
much computer memory will be used to load samples and FFT data. The maximum number of samples is shown. Large files that can't fit within the available memory will be broken into pieces, and you can navigate forward and backward through these pieces using the 

and

buttons.

Another setting is a control to toggle between "Show off dots" and "Hide off dots". For Zero Crossing files, there may be dots that have been marked as "off dots" which are by default excluded from the display and from analysis. By setting this control you can turn these dots back on again.

**Keyboard Shortcuts**

Click anywhere in the Spectrogram Window of the Viewer to set your mouse focus to take advantage of the following keyboard shortcuts:

- Down arrow for next file
- Shift-Down arrow for next folder
- Up arrow for previous file
- Shift-Up arrow for previous folder
- Left arrow to scroll back 1/10th screen width
- Right arrow to scroll forward 1/10th screen width
- Shift-Left arrow to scroll back one screen width
- Shift-Right arrow to scroll forward one screen width
- Space bar for play
- "r" to reload
- "0" to accept auto id label
- "1" - "8" to select the corresponding id label on the top row of customizeable buttons
- "+" or "z" - zoom in x axis
- "-" or "Z" - zoom out x axis
- "=" - zoom to fit x axis
- "." to toggle the zero crossing dots display
- "/" to toggle the compressed/expanded view
Cluster Analysis

You must have a Kaleidoscope Pro license to use the cluster analysis features.

The Kaleidoscope Cluster Analysis module now works in both bat and non-bat analysis modes. A signal detector looks for candidate vocalizations in the recordings, and these vocalizations are then sorted into a number of clusters based on similarity. The resulting clusters can then be quickly reviewed and verified to efficiently survey species present. A more advanced capability allows individual classifications to be manually confirmed to build a more discriminating classifier/detector.

Clustering Modes

The clustering mode can be selected from a pull down selector on the "Cluster Analysis" tab on the Kaleidoscope control panel as follows:

- **DISABLED**
- Scan and cluster recordings to create cluster.kcs and cluster.csv
- Re-scan recordings and edited cluster.csv to create new cluster.kcs with pairwise classifiers and cluster.csv
- Use existing .kcs to sort new recordings and create new cluster.csv

Scan and Cluster Recordings

In this mode, input recordings are scanned for vocalizations consisting of one or more syllables as described in the "Signal Parameters" tab of the Kaleidoscope control panel (see below). The Kaleidoscope clustering algorithms (also described below) are used to sort the data into clusters by similarity. When finished, a cluster.csv file is produced in the output folder listing all the detected vocalizations and their cluster membership, and a cluster.kcs file is also produced containing a representation of the clusters that can be re-used to sort new data against the same clusters.

Re-scan recordings and edited cluster.csv

In this mode, you would first edit the cluster.csv file with labels in the "Manual ID" column and place the edited cluster.csv file at the top of the inputs folder. The data is then rescanned. Vocalizations overlapping with labeled rows in the input cluster.csv file are re-clustered while all other vocalizations are discarded and ignored. In this way, new clusters can be learned that are associated with specific vocalizations. Additionally, if there are two or more different labels in the cluster.csv file, additional pairwise classifiers will be constructed to improve discrimination between overlapping classes to reduce false positives. A new cluster.kcs file is produced in the output directory containing a representation of the clusters and pair-wise classifiers which can be re-used to sort new data. Additionally, a new cluster.csv file is created in the outputs directory to show the performance of the new classifier against the labeled training data.
Use existing `.kcs` file to sort new recordings

In this mode, a specified `.kcs` file is used to sort a new set of input data to create a new `cluster.csv` file. Thus, an existing `.kcs` file can be created using one or both of the steps above to form a detector/classifier, and this can be applied to new data for detecting or classifying specific species of interest.

Overview of the Clustering Algorithm

**Signal Detection and Feature Extraction**

In non-bat analysis mode: A signal detector searches for candidate vocalizations and extracts the features used for clustering. A candidate vocalization is a "phrase" comprising a sequence of "syllables" occurring close together in time such that the "maximum inter-syllable gap" is not exceeded. Here, a "syllable" is the period between a detected onset above the background noise until the signal drops back towards the noise floor. The signal energy in the phrase is also expected to be constrained to minimum and maximum frequencies and durations. The algorithm estimates the ambient background spectrum through a rolling average of power levels going back in time by the maximum vocalization duration. The spectrum of each FFT frame in each syllable (the "signal frames") are normalized and Discrete Cosine Transform (DCT) coefficients representing the spectrum are extracted. The variable-length sequence of these DCT coefficients of these signal frames forms the feature vector representing the candidate vocalization.

In bat-analysis mode, enhanced zero crossing is performed and the sequence of "dots" representing frequency and dela frequencies are extracted.

**Hidden Markov Model**

A Hidden Markov Model (HMM) is constructed from the vector of DCT coefficients for each signal frame. First, these vectors are clustered using K-Means to form initial estimates for HMM states. Then, the HMM is trained on the candidate vocalizations using the Viterbi algorithm. Note that there is deliberate randomness to the algorithm used to seed initial HMM states during the K-Means clustering. As such, the resulting HMM may vary between different runs resulting in slightly different clustering results.

**Fisher Scores**

The variable length feature vector representing each candidate vocalization is transformed into a highly dimensional fixed length feature vector by calculating the Fisher Score against the underlying HMM model parameters. The magnitude of the Fisher Scores are normalized to unit length and become the basis for comparing two vocalizations for similarity. The dot product of two Fisher Scores is related to the Euclidean distance between two Fisher Scores each normalized to unit length. A distance of zero would suggest the vocalizations are identical, while a distance equal to the square root of 2 (~1.41) suggests the vocalizations are orthogonal. The maximum possible Euclidean distance between two vocalizations is 2.0.
Clustering

Clusters are formed by moving vocalizations to existing clusters if they are within some minimum distance of the cluster. Otherwise, new clusters may be formed.

Pair-wise classifiers

As an extra step that can be taken when vocalization classes are known (e.g. with human supervision), the multi-dimensional hyperplane maximizing the separation between two classes can be formed for each pair of classes. This will often outperform cluster membership alone in classification because it is both more discriminating (by finding separation between overlapping clusters) but also carves out more of the multi-dimensional space (e.g. a vocalization is on one side or the other side of the plane regardless of it's distance to a cluster) to better fit new data that doesn't match closely to the training data.

Clustering Parameters

Parameters in the Cluster Analysis tab

The following parameters found on the Cluster Analysis tab of the

Path to input .kcs file

When scanning using an existing cluster set, the path of the .kcs file is specified here.

Max distance from cluster center to include outputs in cluster.csv

This is the maximum distance of a given vocalization to the closest cluster center that will be included in the output cluster.csv file. Vocalizations that are further away from this will be filtered out and excluded in the output .csv file. Since the maximum possible distance to any cluster is 2.0, a value of 2.0 will include all detected vocalizations in the output cluster.csv file. However, distances approaching or exceeding the square root of 2 ( = ~ 1.41 ) are orthogonal to the cluster center and would not be considered a match. Values less than 1.0 are likely better matches.

FFT Window (non-bat analysis mode only)

The algorithms are designed to be tolerant of different sample rates by standardizing on an FFT frame rate and automatically using larger FFTs for higher sample rates and smaller FFTs for lower sample rates. This said, for best results, we would recommend standardizing on a single sample rate if possible. There are three available frame rates at this time. These are 2.67ms, 5.33ms, and 10.67ms. For a given sample rate and FFT size, the window overlap is adjusted to produce the standardized frame rate. Additionally, since FFT sizes are optimized at powers of 2, one FFT size is used for sample rates...
between 0-24kHz, an FFT size of two times this is used for sample rates between 25-48kHz, and an FFT size of four times this is used for sample rates above 49kHz.

Max states

This is the target size of the Hidden Markov Model as a number of states. Experience shows that values between 8 and 16 are usually good for most applications. A larger number of states may be necessary in environments with a more diverse set of acoustic signals and may help tease apart more subtle differences between similar vocalization classes. However, too many states may result in "noisy" dimensions resulting in poor clustering.

Max distance to cluster center for building clusters

This parameter controls how vocalizations form clusters. When analyzing a new vocalization, if the closest existing cluster is within this distance, then the vocalization is assigned to this cluster. Otherwise, a new cluster may be formed. This is also the distance used to merge two clusters together. Experience shows that a value of 0.5 works well. Higher values will cause fewer clusters to be formed from more vocalizations and lower values will cause more clusters to be formed from fewer vocalizations.

Max clusters

This parameter limits how many clusters are formed. The clusters with the highest number of member vocalizations are given priority while clusters with fewer members are discarded to fit within this maximum.

Cluster Results Table

The cluster.csv file generated has a row for each detected vocalization and the following columns:

FOLDER

The directory path from the input directory to the file containing the vocalization.

IN FILE

The filename of the file containing the vocalization.

CHANNEL

The channel number (0 = left, 1 = right) containing the vocalization.

OFFSET
The offset into the file in seconds to the start of the detected vocalization.

DURATION
The duration of the vocalization in seconds.

Fmin
The lowest frequency signal detected in any signal frame across the vocalization

Fmean
The mean peak frequency signal detected across the vocalization.

Fmax
The highest frequency signal detected in any signal frame across the vocalization

DATE
The date stamp of the vocalization if available

TIME
The time stamp of the vocalization if available

HOUR
The hour (from time) of the vocalization if available

DATE-12
The date stamp of the vocalization if available less 12 hours (for nightly folders)

TIME-12
The time stamp of the vocalization if available less 12 hours (for nightly folders)

HOUR-12
The hour (from time) of the vocalization if available less 12 hours (for nightly folders)

TOP1MATCH, TOP2MATCH, TOP3MATCH
The top 1st, 2nd, and 3rd cluster (or winning pair-wise label) from best to worse match
TOP1DIST, TOP2DIST, TOP3DIST

The distance to the cluster center corresponding with the 1st, 2nd and 3rd matches

VOCALIZATIONS

The value of "1" for convenient pivot table counting

MANUAL ID

A user defined label that can be assigned subsequently

When a cluster scan is complete, the Kaleidoscope Viewer is launched and linked with a results window containing a subset of the above columns. The displayed columns can be edited by using the "File->Edit columns..." menu on the results window. All of the MANUAL ID entries corresponding to a given TOP1MATCH in the selected row can be changed in bulk using the "File->Bulk ID..." menu on the results window.

When using the "Scan and cluster recordings..." mode, the cluster labels in the resulting cluster.csv and cluster.kcs files are set to "cluster.000", "cluster.001", "cluster.002", and so on. These labels can be changed to an arbitrary label in both the cluster.kcs and cluster.csv file by using the "File->Edit cluster name..." menu in the results window. When the results cluster.csv is saved with "File->Save", the labels in the cluster.kcs file will also be saved. This allows you to name clusters with a useful label such as a species name. You can then run a new data set using the same cluster.kcs file and the TOPnMATCH fields in the resulting cluster.csv will be set to the customized labels.
Noise Analysis Module

You must have the proper license to use the Kaleidoscope Noise Analysis Module features.

The Noise Analysis Module is used to scan a batch of recordings of marine and terrestrial acoustic data to analyze the noise spectrum and generate a report of noise levels in accordance to various standards. Note that this is probably not useful for triggered ultrasonic recordings used by bat researchers.

On the Kaleidoscope control panel, open the "Noise Analysis" tab to enable and configure the Noise Analysis Module. Analysis is performed during a batch scan (from the Kaleidoscope "Batch" panel) and results are written to the file "noise.csv" in the output directory.

Noise Module Requirements

The Noise Analysis Module is designed to work with recordings made with Wildlife Acoustics audio recorders and assumes files use the Wildlife Acoustics file naming convention.

Most protocols require monitoring for long periods of time in order to acquire meaningful data for reporting. Triggered .wac files are not supported. Only continuous .wav and .wac files should be utilized.

Most protocols require measurements in certain bands of frequencies. Recordings must be made at a sufficient sample rate in order to resolve these frequencies. Sample rates must be more than twice the highest frequency to be measured.

Supported Measurements

The Noise Analysis Module supports many commonly used measurements. Each measurement typically involves a weighted band of frequencies as listed below.

- Third octave bands are supported with centers between 19.7Hz and 161,270Hz.
- A Weighted
- B Weighted
- C Weighted
- D Weighted
- NOAA combined marine mammal filters including:
  - Low-frequency cetacean
  - Mid-frequency cetacean
  - High-frequency cetacean
  - Pinniped Phocid
  - Pinniped Ottarid
- 10Hz - 10,000Hz unweighted
- 10Hz -192,000Hz unweighted
For each recording, Kaleidoscope automatically chooses an FFT size that is the lowest power of two that is greater or equal to the sample rate. Hanning windows are used with 50% overlap. This ensures frequency resolution of less than or equal to 1Hz and time resolution between 0.5 and 1.0 seconds for each FFT measurement. Results are aggregated into one second periods and normalized to 0dB for a full scale input signal.

**Configuring the Noise Analysis Module**

The following configuration parameters and settings can be specified from the "Noise Analysis" panel of the Kaleidoscope main window.

**Enable noise analysis**

Check this box to enable the noise analysis module. Once enabled, any batch scans will run the data from suitable files through the Noise Analysis Module and a "noise.csv" report will be generated in the batch output directory.

**Select weighted bands**

Specify the desired weighted frequency band measurements by checking one or more of the measurements listed.

**Min SPL**

Check this box to include a minimum Sound Pressure Level column for each selected measurement band.

**Mean SPL**

Check this box to include a mean Sound Pressure Level column for each selected measurement band.

**Max SPL**

Check this box to include a maximum Sound Pressure Level column for each selected measurement band.

**SELcum**

Check this box to include a cumulative Sound Exposure Level column for each selected measurement band.

**Sample period (minutes)**

Select the sample period size in minutes. The report will include a row for each sample period (one for each recorder channel). Minimum and maximum values correspond to the
minimum and maximum value of any full one second period contained within the sample period.

**dB adjustment**

The dB adjustment is added to each measurement. This can be used to adjust the reference scale e.g. from 0 dB = full scale to 0 dB = 20 micro-Pascals. Note the additional adjustments that might be made automatically from meta data contained within the recordings (see below).

**SEL peak threshold above mean**

When making cumulative Sound Exposure Level measurements, Kaleidoscope looks through the sample period one second at a time to find sound events to accumulate. A sound event must have a peak Sound Pressure Level above the mean by this threshold.

**SEL off threshold above mean**

When making cumulative Sound Exposure Level measurements, Kaleidoscope adds up Sound Pressure Levels on either side of the event peak until the Sound Pressure Level falls below this threshold above the mean

**Noise Analysis Module Outputs**

The output of the Noise Analysis Module is the *noise.csv* file written to the batch output directory.

Output rows are organized by recorder channel. Kaleidoscope uses the recorder's unique prefix, and stereo recordings are segregated into channel zero and channel one.

For each recorder channel, a row of data is generated for each sample period.

For each row, the following columns are generated:

**Prefix**

The recorder prefix (from the filename). Kaleidoscope assumes that each individual recorder has a unique prefix.

**Channel**

Indicates the channel number in the recording.

**Date**
Indicates the date in YYYY-MM-DD format corresponding to the start of the sample period.

**Time**

Indicates the time in hh:mm:ss format corresponding to the start of the sample period.

**Samples (s)**

Indicates the actual number of seconds contributing to the sample period. This would usually be the same as the sample period as specified. But Kaleidoscope will also process periods where there are gaps in the available recordings.

**Correction (dB)**

Indicates the combined correction factor applied to the full-scale recordings to produce the results. This includes the user-specified "dB Adjustment" value combined with any meta data adjustments from the recordings.

**Bands**

What follows will be a group of columns for each of the selected measurement bands. For each measurement band, there is also a column for each of minimum, maximum, mean, and cumulative SEL as selected.

**Use of Meta Data**

The Song Meter SM3 family of recorders (firmware version 1.1.9 and later) and future recorders have the ability to include additional meta data encapsulated in .wav files. In particular, the end-user can specify the microphone sensitivities (e.g. in dBV/Pa). This information is combined by the firmware with information about gain and full scale voltages to produce a correction factor. The correction factor is combined with the "dB Adjustment" from the Kaleidoscope Noise Analysis Module to adjust the reported calculations.

The best practice would be to measure and specify the microphone sensitivities in the recorder settings before deployment. For acoustic microphones, a standard microphone calibrator can be used to produce a 94dB SPL (1 Pa) 1kHz tone at the microphone while the SM3 is in "Microphone Calibrate" mode. This will display the dBV of the 1Pa tone. The value displayed can be manually entered into the "Microphone Sensitivity" settings on the recorder. Then, Kaleidoscope data would automatically be adjusted to dBV/Pa. To measure SPL relative to 20 micro-Pascals, the Kaleidoscope "dB Adjustment" can be set to 94.0dB.

For older recorders, batches would need to be done on one recorder at a time and the "dB Adjustment" would need to be determined for each recorder. To show SPL relative to 20 micro-Pascals, the dB adjustment should be 94.0dB (1 Pa re 20 micro-Pascals) plus the microphone...
sensitivity (dBV/Pa) plus the recorder gain (dB) plus the adjustment for full scale voltage from the table below.

**Recorder Sample rates <= 96000 Sample rates > 96000**

<table>
<thead>
<tr>
<th>Recorder</th>
<th>&lt;= 96000</th>
<th>&gt; 96000</th>
</tr>
</thead>
<tbody>
<tr>
<td>SM2</td>
<td>+0.0dB</td>
<td>+1.9dB</td>
</tr>
<tr>
<td>SM3</td>
<td>+0.0dB</td>
<td>+1.9dB</td>
</tr>
</tbody>
</table>
Kaleidoscope Release Notes 4.3.1

Version 4.3.1

Fix problem writing correct meta data to output files during batch

Simplified Analook zero crossing file Species field output

Added support for GUANO "Original Filename" field

Added GUANO "WA|Kaleidoscope|Auto ID" field to preserve auto ID result after running through other programs

Fixed crash after saving edited WAV file in viewer

Version 4.3.0

GUANO metadata support (Kaleidoscope Pro license only)

GUANO metadata developed by David Riggs (guano-md.org) is now supported in Kaleidoscope Pro. Kaleidoscope both reads and writes GUANO information and maintains GUANO side-by-side with existing WAMD meta data formats. Kaleidoscope Viewer will show any GUANO metadata present in the file at the end of the metadata notes window and will begin with a line of the form "GUANO|Version:1.0". Field values can be edited and additional GUANO meta data fields can be added. Additionally, during batch processing, custom GUANO meta data fields can be added to the outputs by specifying lines beginning with "GUANO|Version:1.0" in the batch tab input meta data window.

New bat auto id classifiers

Add new 4.3.0 bat classifiers for North America, Neotropics, Europe, and South Africa with minor tuning improvements over 4.2.0 optimized for improvements to call trending and zero crossing conversion. Also updated some common names of species.

New default classifier setting "Balanced"

This is our recommended setting balancing between liberal and conservative classification, especially with the latest classifiers. If you prefer to see less NoID and more classification to species, use the "More Sensitive" setting, and if you prefer to have more NoID and more accurate classifications, you might try the "More Accurate" setting.

Improved zero crossing call trending

Add feature to locate input files when opening results
When opening a results file such as id.csv, meta.csv or cluster.csv, the input path needs to be specified in the control panel to locate the corresponding files. If this is not set correctly, the results window cannot load files into the viewer. The results window will now launch a dialog to let you browse the filesystem to locate the selected file and thereby learn the correct input file location.

Add results window Bulk Id of selected rows

Bulk ID (by manual ID or selected rows) for id.csv now updates output file meta data as well

Bulk copy files in selected rows to a specified folder (bat analysis mode and .wav or zero crossing files only)

Add Bat Auto ID option to clear all selected classifiers

Remove size restrictions on ZC files

Saving selected samples to a WAV file now writes meta data

Improve error handling in viewer when opening corrupted files

Fix bug causing occasional crash in viewer when changing files

Fix bug in which timestamp meta data was not being used in result .csv files

Fix handling of daylight savings time

Recorders typically do not adjust for daylight savings time, resulting in ambiguities in date/time calculations if a recording is made during the non-existing hour at the end of daylight savings time (e.g. before the clock is advanced by one hour). In prior versions, if the recorder's timestamp fell within this hour, it was advanced by one hour. However, this could result in duplicate entries. With this version, daylight savings time is ignored and the timestamp is not advanced.

Fix handling of noise filtering option for ZC-to-ZC files

Fix viewer bugs related to X/Y scaling when changing display modes

Fix bug causing Auto ID indication in viewer to not be updated with cluster label when clustering in Bat Analysis mode

Update common names of North American bat species

**Version 4.2.0**
Add support for 4.2.0 bat classifiers to increase sensitivity (less conservative). The balanced setting is similar to previous more sensitive setting, and the more accurate setting is similar to the previous balanced setting.

Improve initial HMM model estimates for clustering with reduced randomness.

**Version 4.1.0**

Add clustering analysis for bat analysis mode

In bat-analysis mode, ultrasonic data (full spectrum and/or zero crossing) can now be clustered. A demo license enables this feature up to 100 files.

Add new 4.1.0 bat classifiers

New classifiers based on new clustering algorithms for North America, Europe, Neotropics and South Africa. Now all species codes are standardized to 6 characters (first three letters of genus followed by first three letters of species). These classifiers are more conservative than previous versions (meaning, more likely to indicate NoID for ambiguous cases) and more accurate.

Add shortcut key "/" to toggle expand/compress view

Add DATE-12, TIME-12, HOUR-12 fields to output cluster.csv

Add analysis window measurements for minimum, maximum and mean power levels in dB relative to full scale.

Batch processing progress bar now shows total batch size in files and gigabytes

Viewer window now has Toggle Reference instead of Open Reference on the file menu and now toggles the virtual call library on and off in the spectrogram

Fix consistency problem in noise scrubber not matching classifier

Fix creation of bandpass filter if mouse leaves the Y-azis before releasing the mouse button.

Fix bug causing possible corruption of results.

Fix bug causing possible hang when reading badly formed wav file

For advanced users who need to repetitively and programmatically launch Kaleidoscope in batch mode, you can specify --batch on the command line followed by a settings.ini file. Any non-default settings will be overridden by the contents of the settings.ini file and the "Process Files" button will be automatically pressed. When the batch is complete, Kaleidoscope will exit instead of launching the results window and viewer. There is no
error checking and this is a limited capability but should satisfy some requests we've had for making it possible to launch Kaleidoscope from a script.

Version 4.0.2

Kaleidoscope Viewer is now free and no longer requires a license

Version 4.0.1

Fix bug causing ZC file corruption with long unicode meta data

Fix bug causing crash when opening reference from control panel

Additional memory management improvements

Version 4.0.0

Added Cluster Analysis

Cluster analysis detects and sorts vocalizations into clusters based on similarity. This powerful feature makes it fast and easy to review large data sets to survey different vocalizing species, search for specific vocalization types, or build classifiers from training data to find similar vocalizations in new data. At this release, the feature is only available for acoustic (non-ultrasonic) full spectrum recordings.

Added South African bat classifiers (beta).

User interface overhaul for improved ease-of-use.

• The analysis mode selection for bats or non-bats is now in the upper left corner of the control panel
• Settings not appropriate for a given mode are greyed out and tabs on the control panel indicate a red "X" if disabled.
• The noise filtering and GPS track controls have been moved to the batch outputs, there is no more "GPS" tab.
• The fast/slow control has been moved to the upper right of the control panel and now lets you choose the number of parallel threads used during batch processing.
• The "Filter" tab is now called "Signal Parameters" for defining the nature of the signals to be processed. These values are used in zero crossing conversion, noise filtering, and auto ID.
• The "Classifiers" tab is now called "Auto ID for Bats".

Added short-cut keys in viewer (click on spectrogram for focus)

• Down arrow for next file
• Shift-Down arrow for next folder

Copyright © 2017 Wildlife Acoustics, Inc.
• Up arrow for previous file
• Shift-Up arrow for previous folder
• Left arrow for going backward 1/10th screen width
• Right arrow for going forward 1/10th screen width
• Shift-Left arrow for going backward one screen width
• Shift-Right arrow for going forward one screen width
• Space bar for play
• "r" to reload
• "0" to accept auto id label
• "1" - "8" to select the corresponding id label on the top row of customizeable buttons
• "z" or "+" - zoom in X axis
• "Z" or "-" - zoom out X axis
• "+" - zoom to fit X axis
• "." to toggle the zero crossing dots display

Add ability to bulk label manual ids from auto ids (see File->Bulk ID... on results table window).

Add ability to edit which columns are displayed in viewer results and in what order (see File->Edit columns... on results table window).

Change name of idmeta.csv file to meta.csv file which is now always created during a batch scan to extract meta data from the input files. Now includes GPS coordinates, recorder model, serial number, firmware, prefix and field notes if available.

Improve performance of viewer results window with a large number of results.

Add support for some AIFF files

Add MATCH RATIO column to id.csv, the ratio of matching pulses to the total. This is now shown by default in the viewer results table while the MARGIN column is now hidden by default.

No longer insert channel number in output filename if input file is mono WAV or ZC

Automatically sort results after batch scan. For Auto ID, results are sorted alphabetically by Auto ID in decreasing order of matching pulses and match ratio. For cluster results, clusters are sorted alphabetically in increasing order of distance.

Numerous performance and efficiency enhancements.

Fix several bugs causing the program to crash.

Fix bug causing occasional wrong bat id result on large parallel batches.

Fix and improve algorithms used to extract zero crossing information from full spectrum recordings.
Fix sorting of hierarchical columns in viewer results.

Fix bug preventing manual id column from sorting correctly.

Fix bug causing warning message pop-up in viewer when renaming files or moving files to noise folder on some platforms.

Fix bug parsing odd length meta data from Echo Meter Touch

Fix bug causing ZC to WAV synthesis with incorrect frequency

Fix bug preventing empty ZC files (e.g. with no dots) from being scrubbed

Fix bug preventing zero crossing files to be named correctly when input is a zero crossing file and 8.3 mode is selected

Fix species list for Western Canada bats in the Bats of North America 3.1.0 classifiers.

**Version 3.1.8**

Viewer can now open .zc file extensions

**Version 3.1.7**

Fix occasional crash on start on Mac and Linux

**Version 3.1.6**

Fix possible meta chunk data encoding and corruption problem

MLE with infinite mathematical probability incorrectly produced a p-value of 1 instead of 0. Note the U.S.F.W.S. has not yet re-tested this change, but we fully expect no significant differences with their test data.

**Version 3.1.5**

Fix crash on zero-dot ZC file input.

Add explanation of MLE P-values to help.

Fix parsing odd-length chunks in WAV files

**Version 3.1.4B**

MLE P-value calculation correction
A bug was discovered in the gradient ascent algorithm that could in some cases produce erroneous P-value results. This change has been tested and approved by the U.S.F.W.S for use with the Indiana bat protocol.

Fix compatibility with modified AnalookW file format

Previous versions of Kaleidoscope will not open new AnalookW files containing additional meta data.

**Version 3.1.3**

New Europe and Neotropics classifiers

Improvements to clusters and pass-level processing for European and Neotropical classifiers

**Version 3.1.2**

North American Classifiers 3.1.0 now approved by U.S.F.W.S

The 3.1.0 version of North American classifiers have been approved for use by the U.S. Fish and Wildlife Service for the Indiana bat protocol. This release no longer includes the previously approved version 2.2.2.

Improve handling very short files

When files are shorter than 0.51 seconds in duration, the enhanced zero crossing (and thus classification algorithms) are now better able to extract and analyze pulses. This affects conversion from full spectrum to zero crossing and auto ID of very short files. We continue to recommend longer recordings e.g. at least a full second in duration.

Fix problem classifying unidentifiable files as noise

A bug introduced in 3.0 may cause some files containing bats that get past the filters to be classified as noise if there are no identifiable pulses e.g. all pulses are shorter than 2ms.

Fix bug causing reference view to appear when loading results

If you load id.csv results and Kaleidoscope can not find a matching file to display, the reference view is shown. Now instead a pop-up error window is displayed.

Fix bug causing crash when pressing "Noise" button on viewer

There were a few cases resulting in an application crash when pressing the "Noise" button on the viewer to mark a file as noise. This has been corrected.
Fix bug causing crash on first launch after fresh install

Fix European Species List

   Removed VEMU from U.K. region and fixed spelling of Myotis nattereri.

Version 3.1.1

Add Neotropi-only license

Add license upgrade renewal infrastructure

   Kaleidoscope licenses have always been offered with one full year of product updates included. Up to this point, after over two years, we have not charged for updates. Effective June 1, 2015, we will begin charging an annual upgrade fee after the first year of updates. At this time, pricing for annual updates after the first year is 20% of the list license fee.

Version 3.1.0

Bat vs. Non-Bat Analysis Modes

   Kaleidoscope has several settings and parameters that are specific to past and present conventions for recording bats (e.g. time expansion) that are not suitable for the conventions used to analyze other kinds of recordings. The first time you launch this version of Kaleidoscope, or after setting defaults, you will be asked to choose either "Bats" or "Non-bats" as your preferred analysis mode. You can also change your preference at any time using the control at the bottom of the control panel. The control affects the analysis frequency and time ranges as specified on the "Filter" tab as well as the meaning of the "Auto" time expansion settings.

New Bats of North America 3.1.0 bat classifier

   This is largely based on the 3.0.0 classifier except for removing one weak cluster for MYSO to reduce MYSO false positives. Also modified per-state default species lists by adding LACI, LANO, MYCA and MYYU to Alaska and MYCI to Arizona.

Fix thresholds for sensitive/accurate settings

   The "Balanced" and "More Accurate" settings were not using the correct thresholds resulting in many fewer classifications for several species. This has been corrected with 3.0.0 and newer classifiers at this 3.1.0 release. (Older classifiers will produce the same results as before for backward compatibility). In general, there should be little difference between these settings except for a few species that tend to contribute the greatest to false positive errors.
Fixed missing MYNA from licensed UK bat classifier list

Add ZC file editing

For power users, ZC files may contain "hidden" dots which are not displayed or analyzed by default. In "Advanced Settings" in the viewer, you can change your preference to show or hide these dots (they are hidden by default). Additionally, you can select dots and right-click in the selection to pop up a menu with "Turn off dots" to hide the dots in the selected time range.

Revision to idsummary.csv output format

Columns are now produced for all enabled classifiers, not just classifiers with detections. This will help confirm which classifiers were selected to produce a given set of outputs for better traceability.

Analysis window frequency axis now tracks spectrogram

The zoom and scroll of the analysis window frequency axis will now follow the spectrogram making it easier to zoom in on a portion of the frequency bandwidth for more detailed analysis.

Support for new .zc file extensions

AnalookW files can now use .zc file extensions.

Fix scan crash

Fix a bug in which file in the input directory containing no file extension or a file extension with fewer than three characters could cause a crash.

Fix viewer crashes

A few problems causing the viewer to crash have been fixed. These include opening a triggered WAC file with no triggers, or opening large files where analysis produces more than 32,768 divided zero-crossings.

Fix ZC output encoding

When converting to zero crossing files, there was a bug in the encoding of long time period that could affect the accuracy of TBC measurements.

Fix incorrect spectrogram color

There was a bug in the color calculations in the spectrogram that could cause subtle artifacts on the display.
Fix width of frequency axis

The frequency axis ruler was too narrow to correctly display frequency information.

Fix possible hang in noise analysis module when calculating SEL

**Version 3.0.0**

Improved classification algorithms

In 3.0.0 and later classifiers, there are numerous improvements to their accuracy, sensitivity, and consistency. These include additional training data, improved filtering of training data to remove outliers, and incorporation of new traditional call parameters to supplement the Hidden Markov Model Fisher Score parameters already used.

Replace UK classifiers with European classifiers

At this release, there is now a "Bats of Europe" classifier replacing previous UK-only classifiers. A UK license can only select those species normally found in the UK.

Add measurements of bat call parameters

The analyze window in the viewer now includes common measurements of bat echolocation calls including duration, time between calls, minimum, maximum and mean frequency, characteristic frequency, slope and time offset, initial slope, and the frequency and time of the knee. These parameters are also output in tabular format in the *id.csv* file when performing batch identification available in Kaleidoscope Pro.

The zero crossing display in the viewer now also highlights the body of the call between the knee and characteristic frequency in purple. The button previously used to toggle the zero crossing portion of the display on and off now has three states and can be used to show the dots as before, the dots with the body of the call highlighted as described above, and off.

Alternate identifications

The *id.csv* now has an added column for alternative identifications listing in rank order any other pulse-level identifications detected in the file suggestive of alternate possible identifications or the presence of multiple bats.

Improve scaling preferences for expanded and compressed views

The zoom levels in expanded and compressed views are now separated so that you can set preferred zoom levels for these two modes independently and easily toggle between compressed view with one zoom level and expanded view with another. You can also toggle between your preferred zoom level and the "zoom to fit" modes.
Add support for reviewing noise files in classification results

If the "Keep noise files" checkbox is checked on the "Filter" tab, then files tagged as noise will be included in the viewer results window and you can click on them to review the noise files.

Add button to move to noise

A "Noise" button on the meta data panel will now move the currently viewed file to the "NOISE" folder and automatically advance to the next file.

Add ability to rename file

A "Rename" button on the meta data panel will pop up a dialog to edit the filename of the currently viewed file.

Add pulse counts for NoID and noise file outputs in id.csv.

Fix inconsistency in noise vs. noid

There was an inconsistency in which some files containing no identifiable pulses are classified as NoID and should have been classified as noise.

Add ability to customize viewer colors

You can now customize all the viewer colors to suit your personal preferences.

Add ability to save viewer screenshots

Use "File"->"Save Screen" to save the waveform and spectrogram as a .jpg image file.

Add ability to save samples

Use "File"->"Save Samples..." to save selected full spectrum samples as a .wav file (also bandpass filtered and gain adjusted by the brightness slider).

Brightness slider now adjusts waveform plot

The brightness slider now adds or removes gain from the samples displayed in the waveform plot (samples are still constrained to 16 bit values and will clip with excessive gain). This is useful to visualize the adjusted samples as these are used for playback and saving waveforms.

Improvements in classifying noisy native zero crossing recordings

More of the calls will be classified when using new 3.0.0 and later classifiers.
Additional improvements to MLE calculations

Continuing to fine tune estimates of classification errors to improve MLE calculations. These improvements only affect classifier versions 3.0.0 and greater in order to preserve outputs with older versions.

Shortened metadata stored in ZC files

Encoding of meta data is now shorter in ZC files using "(KS" instead of "(Kaleidoscope" to save space in the species id field. You will now need Kaleidoscope 3.0.0 and newer to read this new meta data created by other Kaleidoscope 3.0.0 and newer versions.

Add 10Hz-192kHz unweighted band for noise analysis module

Fix crash when changing classifiers with viewer open

Fix crash when viewing some files in compressed view at certain zoom levels.

Fix problem interpreting Sonobat time expansion meta data

**Version 2.3.0**

Add beta version of European classifiers to try with UK/Pro license

Improve performance of classifier results table sorting

Increase max supported sample rate from 953kHz to 1072kHz

Improve conversion of zero crossing to synthesized wav files

Add Fast/Slow modes for resource constrained machines

Fix bug causing crash after extracting 8K GPS waypoints in one file

Fix bug causing crash on MacOSX when changing channels in viewer

Fix bug in noise analysis module causing exclusion of some input data

Fix bug handling large files

When opening a large file in the viewer, depending on available memory, it might be split into two or more segments. There was a bug in causing one too few segments to be created.

**Version 2.2.2**
Correct MYSE classifier

EPFU could be misclassified as MYSE

Correct classification inconsistency

When batch processing WAC files or breaking WAV files into smaller pieces, there was a possibility of producing slightly different zero crossing information which could also result in slightly different classification results when compared to processing individual WAV files.

Version 2.2.1

Improve MLE P-value calculations

Version 2.2.0

Updated North American and Neotropic classifiers

Improvements cleaning up training data for COTO, MYCA, MYTH, MYSE, MYYU, PAHE

Noise Analysis Module

Added new noise analysis module for batch analysis of noise levels.

Viewer Spectrogram

The spectrogram in the viewer changed how windowing is implemented. You may need to adjust FFT size and window size in the "Advanced Settings" to adjust the display to your liking.

Viewer Waveform Log View Plot

The plot are was off by a little bit to the scale, now fixed

Viewer Analysis Window

Cursor is now locked to the spectrum line

Classifier Checkboxes

Changed user interface to show all individual classifier selections in a scrollable list.

Version 2.1.1
Added beta release of Bats of the Neotropics classifiers

Use new directory browsing control on batch panel

Analysis window cursor now displays mean and cumulative dB power spectrum

Analysis window you can now left-click copy to copy raw data to the clipboard and then paste it to a spreadsheet.

Fix problem related to viewing triggered WAC files

Fix problem playing back right channel of stereo recordings

Opening viewer no longer opens control panel window

Version 2.1.0

Improvements to Zero Crossing Extraction from Full Spectrum

Previous versions excluded the first and last "dot" in the sequence of smooth dots forming a call. This change improves zero crossing extraction, call detection and classification performance as a result. The new 2.1.0 classifiers are tuned to work with this change.

Fix detection and classification of low frequency bats

Previous versions continued to filter frequencies below 16kHz for classification even though new low-frequency bats below 16kHz were introduced in the classifiers resulting in poor performance. This has now been corrected.

Change the regional buttons on the classifier page to a pull-down list

Now larger classifiers can be created with more regions e.g. U.S. states.

Add "Zoom to fit" for selection boxes

Now if you right click inside a selection box within the spectrogram or waveform view, a pop-up menu appears. Right now the only choice is to "Zoom to fit" which will expand the selected region to fill the corresponding windows.

Fix "About" page on classifier tab

This was broken on a previous release and now fixed.

Version 2.0.7
Fix handling of GPS output on stereo recordings
UK classifiers back to Myotis genus-level only and improved

Version 2.0.5
Minor improvements to classifiers
Fix crash on opening results window with non-ASCII characters in filenames

Version 2.0.4
Fix UK classifiers now at 2.0.3

Version 2.0.3
Another fix for UK-only license problem causing crash on launch

Version 2.0.2
Revision to UK classifiers to fix problems in training data
Fix spectrogram window focus handling

Version 2.0.1
Fix UK-only license problem preventing UK classifiers from being selected

Version 2.0.0
Add reference call cluster display in viewer (for new classifiers)
Support for improved classifiers at version 2.0.0
Support for playback of Echo Meter Touch voice notes
Support for Echo Meter Touch metadata including GPS
Improve filtering and signal detection algorithms
Improve time/date parsing in filenames with suffixes
Improve progress bar calculations
Improve compatibility with other recorders
Improve import and export of settings

Change filter defaults for low frequency bats

Fix occasional crash on launch

Fix occasional crash on processing incorrectly formatted wav files

Fix for Mac to open ZC files from file open dialog

Upgrade to wxWidgets-3.0.0

**Version 1.1.22**

Fix bug in zero cross conversion

    High frequency noise was not being filtered out correctly.

**Version 1.1.21**

Add UK classifier version 1.0.5 with new PINA data

**Version 1.1.20**

Fix zero crossing conversion with split to max duration

Make zero crossing output noise filtering consistent with full spectrum during conversion

**Version 1.1.19**

Fix bug in KML GPS reporting when within one degree west of meridian

**Version 1.1.18**

Add noise and auto-id to GPS outputs

**Version 1.1.17**

Fix selection playback when box drawn backward (not actually fixed in 1.1.16)

**Version 1.1.16**

Fix memory corruption problem causing corrupted id results

Added support for UK only license
Version 1.1.15

Improve audio quality of sound playback

Add Linux support for sound playback

Allow spaces in species labels for user-defined buttons

Work around pre Wac2Wav 3.2.6 bug

Old versions of Wac2Wav created zero-crossing files with incorrectly formatted date information in the meta data which then confuses Kaleidoscope. Kaleidoscope now detects and corrects for this condition.

Version 1.1.13

Add sound playback at various speeds

The play button will start playing the displayed spectrogram or selection. Several playback speeds for faster/slower playback are available. The brightness control doubles as a volume control.

Add "Auto" choice in input wav time expansion choice

If the time expansion factor for input WAV files is set to "Auto", then the time expansion factor will be determined either first by meta data present in the file, or second by the sample rate with the assumption that files sampled at \( \leq 96\)kHz are 10X time expansion while files > 96kHz are 1X time expansion.

Add support for parsing Sonobat comments and time expansion factor meta data in wav files

Fix bug where files shorter than 1.1 seconds were not being analyzed

Fix bug where read-only files fail to open.

Kaleidoscope Viewer attempted to open files as writable to update meta data. Now never opens "input files" as writable (e.g. when opened from results window with no output files present), and will open read-only files as read only.

Version 1.1.10

Performance improvement

Previous version changes to P-value calculation caused significant delays after scanning is completed before outputs are generated, especially when a large number of input folders was present.
Version 1.1.9

Improve calculation of P-Values with Maximum Likelihood Estimator

Fix bug in parsing filenames in second batch pass correcting handling of milliseconds and channel numbers. Previously it was possible in stereo recordings for one channel output to overwrite a file from another channel.

Version 1.1.8

Fix bug causing corrupt meta data in ZC file if blank manual id

Fix bug handling daily/nightly directories in viewer results

Version 1.1.7

Add time expansion control to viewer for convenience

Add spectrum analysis window

Performance improvements when displaying log amplitude

Fix bug causing long horseshoe bat vocalizations to be ignored

Fix bug causing crash on large files

Fix bug causing wrong meta data to be written to last files of batch

Fix bug preventing selection of external drive root as input directory.

Version 1.1.4

Fix bug causing occasional crash in viewer

Fix bug causing occasional crash when loading results csv

Work around problem with some badly formatted WAV files

Version 1.1.3

Fix bug causing possible corruption of input BatSound files

When opening a BatSound file in the viewer, the BatSound file header may become corrupted. If this has happened to you, please let us know at support2013@wildlifeacoustics.com so we can help restore your files.
Fix bug preventing the viewer from opening input files under folders

**Version 1.1.2**

Extend demo licenses to at least Jun 30, 2013

**Version 1.1.1**

Add support for Kaleidoscope Viewer

id.csv file now split with summary data in idsummary.csv and detail in id.csv. Columns in id.csv changed for easier manual verification with Kaleidoscope Viewer and pivot table generation. See help files for details.

**Version 1.0.0**

Initial production release