Song Sleuth Support Articles

What version of iOS is required for Song Sleuth?

Song Sleuth will only run on devices running iOS 10 or later.

Here is the complete list of devices that can run iOS 10:

  • iPhone 7 Plus
  • iPhone 7
  • iPhone SE
  • iPhone 6s Plus
  • iPhone 6s
  • iPhone 6 Plus
  • iPhone 6
  • iPhone 5S
  • iPhone 5C
  • iPhone 5
  • iPad Pro (12.9-inch)
  • iPad Pro (9.7-inch)
  • iPad Air 2
  • iPad Air 
  • iPad 4th generation
  • iPad mini 4
  • iPad mini 3
  • iPad mini 2
  • iPod touch (6th generation)

Wildlife Acoustics is proud to support wildlife conservation efforts

Merlin Tuttle's Bat Conservation Orginization for Bat Conservation Bat Conservation International Bat Conservation Trust Wildlife Habitat Counsil