Release Notes

Kaleidoscope Release Notes 4.5.4

Version 4.5.1-4.5.4

Fix various license key and start-up problems

Version 4.5.0

Support for Kaleidoscope Subscriptions

This version introduces a new subscription model to Kaleidoscope Pro licensing.

Add support for Wildlife Acoustics .W4V Compressed WAV files

Kaleidoscope can now open and create .W4V compressed audio files. .W4V files are special .WAV files with Wildlife Acoustics new proprietary compression. You can choose to compress files during batch processing by specifying compression in the outputs section of the "Batch" tab in the control panel. Different levels of compression are offered including 50%, 62% and 75% using W4V-8, W4V-6 and W4V-4 compression modes. This is technically lossy compression by adaptively scaling the dynamic range effectively raising the noise floor to no more than 42dB, 30dB, or 18dB below peak signal levels respectively. W4V-8 offers 2:1 compression with extremely high fidelity.

Add ability to obfuscate GPS coordinates in meta data

The batch tab input controls now have a field "Fuzz GPS to precision" where you can set the precision generated in output files of GPS coordinates in both latitude and longitude. For example, setting this to 0.25 would round all latitude and longitude coordinates to the closest 0.25 degrees (or approximately 28km).

Improve ability to add multiple manual IDs to a file

By holding the control key down when pressing manual ID buttons or number keys, the IDs are appended to the manual ID field separated by commas and "Auto next file" is disabled.

Add additional larger FFT window size option for cluster analysis

A new larger 21.33ms window size option is available which may be suitable for discrimination of lower frequency vocalizations.

Fix bug causing GUANO meta data for Song Meter configuration to repeat the left channel microphone type, gain, and high pass filter settings on the right channel.

Fix bug preventing some zero crossing noise files from being filtered

Fix bug causing some generated .kcs files to be corrupt resulting in a crash when subsequently using them to scan recordings.

Fix extraction of SM4 metadata to reflect the 26.2dB pre-amplifier gain rather than previously specified 24.0dB pre-amplifier gain.

Version 4.3.2

Fix bug causing occasional crash on launching viewer

Fix bug causing next and previous folder buttons to not work when loading a previously saved results .csv file before resorting a column

Fix bug causing search for input files to fail if there are no subfolders

Version 4.3.1

Fix problem writing correct meta data to output files during batch

Simplified Analook zero crossing file Species field output

Added support for GUANO "Original Filename" field

Added GUANO "WA|Kaleidoscope|Auto ID" field to preserve auto ID result after running through other programs

Fixed crash after saving edited WAV file in viewer

Version 4.3.0

GUANO metadata support (Kaleidoscope Pro license only)

GUANO metadata developed by David Riggs (guano-md.org) is now supported in Kaleidoscope Pro. Kaleidoscope both reads and writes GUANO information and maintains GUANO side-by-side with existing WAMD meta data formats. Kaleidoscope Viewer will show any GUANO metadata present in the file at the end of the metadata notes window and will begin with a line of the form "GUANO|Version:1.0". Field values can be edited and additional GUANO meta data fields can be added. Additionally, during batch processing, custom GUANO meta data fields can be added to the outputs by specifying lines beginning with "GUANO|Version:1.0" in the batch tab input meta data window.

New bat auto id classifiers

Add new 4.3.0 bat classifiers for North America, Neotropics, Europe, and South Africa with minor tuning improvements over 4.2.0 optimized for improvements to call trending and zero crossing conversion. Also updated some common names of species.

New default classifier setting "Balanced"

This is our recommended setting balancing between liberal and conservative classification, especially with the latest classifiers. If you prefer to see less NoID and more classification to species, use the "More Sensitive" setting, and if you prefer to have more NoID and more accurate classifications, you might try the "More Accurate" setting.

Improved zero crossing call trending

Add feature to locate input files when opening results

When opening a results file such as id.csv, meta.csv or cluster.csv, the input path needs to be specified in the control panel to locate the corresponding files. If this is not set correctly, the results window cannot load files into the viewer. The results window will now launch a dialog to let you browse the filesystem to locate the selected file and thereby learn the correct input file location.

Add results window Bulk Id of selected rows

Bulk ID (by manual ID or selected rows) for id.csv now updates output file meta data as well

Bulk copy files in selected rows to a specified folder (bat analysis mode and .wav or zero crossing files only)

Add Bat Auto ID option to clear all selected classifiers

Remove size restrictions on ZC files

Saving selected samples to a WAV file now writes meta data

Improve error handling in viewer when opening corrupted files

Fix bug causing occasional crash in viewer when changing files

Fix bug in which timestamp meta data was not being used in result .csv files

Fix handling of daylight savings time

Recorders typically do not adjust for daylight savings time, resulting in ambiguities in date/time calculations if a recording is made during the non-existing hour at the end of daylight savings time (e.g. before the clock is advanced by one hour). In prior versions, if the recorder's timestamp fell within this hour, it was advanced by one hour. However, this could result in duplicate entries. With this version, daylight savings time is ignored and the timestamp is not advanced.

Fix handling of noise filtering option for ZC-to-ZC files

Fix viewer bugs related to X/Y scaling when changing display modes

Fix bug causing Auto ID indication in viewer to not be updated with cluster label when clustering in Bat Analysis mode

Update common names of North American bat species

Version 4.2.0

Add support for 4.2.0 bat classifiers to increase sensitivity (less conservative). The balanced setting is similar to previous more sensitive setting, and the more accurate setting is similar to the previous balanced setting.

Improve initial HMM model estimates for clustering with reduced randomness.

Version 4.1.0

Add clustering analysis for bat analysis mode

In bat-analysis mode, ultrasonic data (full spectrum and/or zero crossing) can now be clustered. A demo license enables this feature up to 100 files.

Add new 4.1.0 bat classifiers

New classifiers based on new clustering algorithms for North America, Europe, Neotropics and South Africa. Now all species codes are standardized to 6 characters (first three letters of genus followed by first three letters of species). These classifiers are more conservative than previous versions (meaning, more likely to indicate NoID for ambiguous cases) and more accurate.

Add shortcut key "/" to toggle expand/compress view

Add DATE-12, TIME-12, HOUR-12 fields to output cluster.csv

Add analysis window measurements for minimum, maximum and mean power levels in dB relative to full scale.

Batch processing progress bar now shows total batch size in files and gigabytes

Viewer window now has Toggle Reference instead of Open Reference on the file menu and now toggles the virtual call library on and off in the spectrogram

Fix consistency problem in noise scrubber not matching classifier

Fix creation of bandpass filter if mouse leaves the Y-axis before releasing the mouse button.

Fix bug causing possible corruption of results.

Fix bug causing possible hang when reading badly formed wav file

For advanced users who need to repetitively and programmatically launch Kaleidoscope in batch mode, you can specify --batch on the command line followed by a settings.ini file. Any non-default settings will be overridden by the contents of the settings.ini file and the "Process Files" button will be automatically pressed. When the batch is complete, Kaleidoscope will exit instead of launching the results window and viewer. There is no error checking and this is a limited capability but should satisfy some requests we've had for making it possible to launch Kaleidoscope from a script.

Version 4.0.2

Kaleidoscope Viewer is now free and no longer requires a license

Version 4.0.1

Fix bug causing ZC file corruption with long unicode meta data

Fix bug causing crash when opening reference from control panel

Additional memory management improvements

Version 4.0.0

Added Cluster Analysis

Cluster analysis detects and sorts vocalizations into clusters based on similarity. This powerful feature makes it fast and easy to review large data sets to survey different vocalizing species, search for specific vocalization types, or build classifiers from training data to find similar vocalizations in new data. At this release, the feature is only available for acoustic (non-ultrasonic) full spectrum recordings.

Added South African bat classifiers (beta).

User interface overhaul for improved ease-of-use.

  • The analysis mode selection for bats or non-bats is now in the upper left corner of the control panel
  • Settings not appropriate for a given mode are greyed out and tabs on the control panel indicate a red "X" if disabled.
  • The noise filtering and GPS track controls have been moved to the batch outputs, there is no more "GPS" tab.
  • The fast/slow control has been moved to the upper right of the control panel and now lets you choose the number of parallel threads used during batch processing.
  • The "Filter" tab is now called "Signal Parameters" for defining the nature of the signals to be processed. These values are used in zero crossing conversion, noise filtering, and auto ID.
  • The "Classifiers" tab is now called "Auto ID for Bats".

Added short-cut keys in viewer (click on spectrogram for focus)

  • Down arrow for next file
  • Shift-Down arrow for next folder
  • Up arrow for previous file
  • Shift-Up arrow for previous folder
  • Left arrow for going backward 1/10th screen width
  • Right arrow for going forward 1/10th screen width
  • Shift-Left arrow for going backward one screen width
  • Shift-Right arrow for going forward one screen width
  • Space bar for play
  • "r" to reload
  • "0" to accept auto id label
  • "1" - "8" to select the corresponding id label on the top row of customizeable buttons
  • "z" or "+" - zoom in X axis
  • "Z" or "-" - zoom out X axis
  • "=" - zoom to fit X axis
  • "." to toggle the zero crossing dots display

Add ability to bulk label manual ids from auto ids (see File->Bulk ID... on results table window).

Add ability to edit which columns are displayed in viewer results and in what order (see File->Edit columns... on results table window).

Change name of idmeta.csv file to meta.csv file which is now always created during a batch scan to extract meta data from the input files. Now includes GPS coordinates, recorder model, serial number, firmware, prefix and field notes if available.

Improve performance of viewer results window with a large number of results.

Add support for some AIFF files

Add MATCH RATIO column to id.csv, the ratio of matching pulses to the total. This is now shown by default in the viewer results table while the MARGIN column is now hidden by default.

No longer insert channel number in output filename if input file is mono WAV or ZC

Automatically sort results after batch scan. For Auto ID, results are sorted alphabetically by Auto ID in decreasing order of matching pulses and match ratio. For cluster results, clusters are sorted alphabetically in increasing order of distance.

Numerous performance and efficiency enhancements.

Fix several bugs causing the program to crash.

Fix bug causing occasional wrong bat id result on large parallel batches.

Fix and improve algorithms used to extract zero crossing information from full spectrum recordings.

Fix sorting of hierarchical columns in viewer results.

Fix bug preventing manual id column from sorting correctly.

Fix bug causing warning message pop-up in viewer when renaming files or moving files to noise folder on some platforms.

Fix bug parsing odd length meta data from Echo Meter Touch

Fix bug causing ZC to WAV synthesis with incorrect frequency

Fix bug preventing empty ZC files (e.g. with no dots) from being scrubbed

Fix bug preventing zero crossing files to be named correctly when input is a zero crossing file and 8.3 mode is selected

Fix species list for Western Canada bats in the Bats of North America 3.1.0 classifiers.

Version 3.1.8

Viewer can now open .zc file extensions

Version 3.1.7

Fix occasional crash on start on Mac and Linux

Version 3.1.6

Fix possible meta chunk data encoding and corruption problem

MLE with infinite mathematical probability incorrectly produced a p-value of 1 instead of 0. Note the U.S.F.W.S. has not yet re-tested this change, but we fully expect no significant differences with their test data.

Version 3.1.5

Fix crash on zero-dot ZC file input.

Add explanation of MLE P-values to help.

Fix parsing odd-length chunks in WAV files

Version 3.1.4B

MLE P-value calculation correction

A bug was discovered in the gradient ascent algorithm that could in some cases produce erroneous P-value results. This change has been tested and approved by the U.S.F.W.S for use with the Indiana bat protocol.

Fix compatibility with modified AnalookW file format

Previous versions of Kaleidoscope will not open new AnalookW files containing additional meta data.

Version 3.1.3

New Europe and Neotropics classifiers

Improvements to clusters and pass-level processing for European and Neotropical classifiers

Version 3.1.2

North American Classifiers 3.1.0 now approved by U.S.F.W.S

The 3.1.0 version of North American classifiers have been approved for use by the U.S. Fish and Wildlife Service for the Indiana bat protocol. This release no longer includes the previously approved version 2.2.2.

Improve handling very short files

When files are shorter than 0.51 seconds in duration, the enhanced zero crossing (and thus classification algorithms) are now better able to extract and analyze pulses. This affects conversion from full spectrum to zero crossing and auto ID of very short files. We continue to recommend longer recordings e.g. at least a full second in duration.

Fix problem classifying unidentifiable files as noise

A bug introduced in 3.0 may cause some files containing bats that get past the filters to be classified as noise if there are no identifiable pulses e.g. all pulses are shorter than 2ms.

Fix bug causing reference view to appear when loading results

If you load id.csv results and Kaleidoscope cannot find a matching file to display, the reference view is shown. Now instead a pop-up error window is displayed.

Fix bug causing crash when pressing "Noise" button on viewer

There were a few cases resulting in an application crash when pressing the "Noise" button on the viewer to mark a file as noise. This has been corrected.

Fix bug causing crash on first launch after fresh install

Fix European Species List

Removed VEMU from U.K. region and fixed spelling of Myotis nattereri.

Version 3.1.1

Add Neotropic-only license

Add license upgrade renewal infrastructure

Kaleidoscope licenses have always been offered with one full year of product updates included. Up to this point, after over two years, we have not charged for updates. Effective June 1, 2015, we will begin charging an annual upgrade fee after the first year of updates. At this time, pricing for annual updates after the first year is 20% of the list license fee.

Version 3.1.0

Bat vs. Non-Bat Analysis Modes

Kaleidoscope has several settings and parameters that are specific to past and present conventions for recording bats (e.g. time expansion) that are not suitable for the conventions used to analyze other kinds of recordings. The first time you launch this version of Kaleidoscope, or after setting defaults, you will be asked to choose either "Bats" or "Non-bats" as your preferred analysis mode. You can also change your preference at any time using the control at the bottom of the control panel. The control affects the analysis frequency and time ranges as specified on the "Filter" tab as well as the meaning of the "Auto" time expansion settings.

New Bats of North America 3.1.0 bat classifier

This is largely based on the 3.0.0 classifier except for removing one weak cluster for MYSO to reduce MYSO false positives. Also modified per-state default species lists by adding LACI, LANO, MYCA and MYYU to Alaska and MYCI to Arizona.

Fix thresholds for sensitive/accurate settings

The "Balanced" and "More Accurate" settings were not using the correct thresholds resulting in many fewer classifications for several species. This has been corrected with 3.0.0 and newer classifiers at this 3.1.0 release. (Older classifiers will produce the same results as before for backward compatibility). In general, there should be little difference between these settings except for a few species that tend to contribute the greatest to false positive errors.

Fixed missing MYNA from licensed UK bat classifier list

Add ZC file editing

For power users, ZC files may contain "hidden" dots which are not displayed or analyzed by default. In "Advanced Settings" in the viewer, you can change your preference to show or hide these dots (they are hidden by default). Additionally, you can select dots and right-click in the selection to pop up a menu with "Turn off dots" to hide the dots in the selected time range.

Revision to idsummary.csv output format

Columns are now produced for all enabled classifiers, not just classifiers with detections. This will help confirm which classifiers were selected to produce a given set of outputs for better traceability.

Analysis window frequency axis now tracks spectrogram

The zoom and scroll of the analysis window frequency axis will now follow the spectrogram making it easier to zoom in on a portion of the frequency bandwidth for more detailed analysis.

Support for new .zc file extensions

AnalookW files can now use .zc file extensions.

Fix scan crash

Fix a bug in which file in the input directory containing no file extension or a file extension with fewer than three characters could cause a crash.

Fix viewer crashes

A few problems causing the viewer to crash have been fixed. These include opening a triggered WAC file with no triggers, or opening large files where analysis produces more than 32,768 divided zero-crossings.

Fix ZC output encoding

When converting to zero crossing files, there was a bug in the encoding of long time period that could affect the accuracy of TBC measurements.

Fix incorrect spectrogram color

There was a bug in the color calculations in the spectrogram that could cause subtle artifacts on the display

Fix width of frequency axis

The frequency axis ruler was too narrow to correctly display frequency information.

Fix possible hang in noise analysis module when calculating SEL

Version 3.0.0

Improved classification algorithms

In 3.0.0 and later classifiers, there are numerous improvements to their accuracy, sensitivity, and consistency. These include additional training data, improved filtering of training data to remove outliers, and incorporation of new traditional call parameters to supplement the Hidden Markov Model Fisher Score parameters already used.

Replace UK classifiers with European classifiers

At this release, there is now a "Bats of Europe" classifier replacing previous UK-only classifiers. A UK license can only select those species normally found in the UK.

Add measurements of bat call parameters

The analyze window in the viewer now includes common measurements of bat echolocation calls including duration, time between calls, minimum, maximum and mean frequency, characteristic frequency, slope and time offset, initial slope, and the frequency and time of the knee. These parameters are also output in tabular format in the id.csv file when performing batch identification available in Kaleidoscope Pro.

The zero crossing display in the viewer now also highlights the body of the call between the knee and characteristic frequency in purple. The button previously used to toggle the zero crossing portion of the display on and off now has three states and can be used to show the dots as before, the dots with the body of the call highlighted as described above, and off.

Alternate identifications

The id.csv now has an added column for alternative identifications listing in rank order any other pulse-level identifications detected in the file suggestive of alternate possible identifications or the presence of multiple bats.

Improve scaling preferences for expanded and compressed views

The zoom levels in expanded and compressed views are now separated so that you can set preferred zoom levels for these two modes independently and easily toggle between compressed view with one zoom level and expanded view with another. You can also toggle between your preferred zoom level and the "zoom to fit" modes.

Add support for reviewing noise files in classification results

If the "Keep noise files" checkbox is checked on the "Filter" tab, then files tagged as noise will be included in the viewer results window and you can click on them to review the noise files.

Add button to move to noise

A "Noise" button on the meta data panel will now move the currently viewed file to the "NOISE" folder and automatically advance to the next file.

Add ability to rename file

A "Rename" button on the meta data panel will pop up a dialog to edit the filename of the currently viewed file.

Add pulse counts for NoID and noise file outputs in id.csv.

Fix inconsistency in noise vs. noid

There was an inconsistency in which some files containing no identifiable pulses are classified as NoID and should have been classified as noise.

Add ability to customize viewer colors

You can now customize all the viewer colors to suit your personal preferences.

Add ability to save viewer screenshots

Use "File"->"Save Screen" to save the waveform and spectrogram as a .jpg image file.

Add ability to save samples

Use "File"->"Save Samples..." to save selected full spectrum samples as a .wav file (also bandpass filtered and gain adjusted by the brightness slider).

Brightness slider now adjusts waveform plot

The brightness slider now adds or removes gain from the samples displayed in the waveform plot (samples are still constrained to 16 bit values and will clip with excessive gain). This is useful to visualize the adjusted samples as these are used for playback and saving waveforms.

Improvements in classifying noisy native zero crossing recordings

More of the calls will be classified when using new 3.0.0 and later classifiers.

Additional improvements to MLE calculations

Continuing to fine tune estimates of classification errors to improve MLE calculations. These improvements only affect classifier versions 3.0.0 and greater in order to preserve outputs with older versions.

Shortened metadata stored in ZC files

Encoding of meta data is now shorter in ZC files using "(KS" instead of "(Kaleidoscope" to save space in the species id field. You will now need Kaleidoscope 3.0.0 and newer to read this new meta data created by other Kaleidoscope 3.0.0 and newer versions.

Add 10Hz-192kHz unweighted band for noise analysis module

Fix crash when changing classifiers with viewer open

Fix crash when viewing some files in compressed view at certain zoom levels.

Fix problem interpeting Sonobat time expansion meta data

Version 2.3.0

Add beta version of European classifiers to try with UK/Pro license

Improve performance of classifier results table sorting

Increase max supported sample rate from 953kHz to 1072kHz

Improve conversion of zero crossing to synthesized wav files

Add Fast/Slow modes for resource constrained machines

Fix bug causing crash after extracting 8K GPS waypoints in one file

Fix bug causing crash on MacOSX when changing channels in viewer

Fix bug in noise analysis module causing exclusion of some input data

Fix bug handling large files

When opening a large file in the viewer, depending on available memory, it might be split into two or more segments. There was a bug in causing one too few segments to be created.

Version 2.2.2

Correct MYSE classifier

EPFU could be misclassified as MYSE

Correct classification inconsistency

When batch processing WAC files or breaking WAV files into smaller pieces, there was a possibility of producing slightly different zero crossing information which could also result in slightly different classification results when compared to processing individual WAV files.

Version 2.2.1

Improve MLE P-value calculations

Version 2.2.0

Updated North American and Neotropic classifiers

Improvements cleaning up training data for COTO, MYCA, MYTH, MYSE, MYYU, PAHE

Noise Analysis Module

Added new noise analysis module for batch analysis of noise levels.

Viewer Spectrogram

The spectrogram in the viewer changed how windowing is implemented. You may need to adjust FFT size and window size in the "Advanced Settings" to adjust the display to your liking.

Viewer Waveform Log View Plot

The plot are was off by a little bit to the scale, now fixed

Viewer Analysis Window

Cursor is now locked to the spectrum line

Classifier Checkboxes

Changed user interface to show all individual classifier selections in a scrollable list.

Version 2.1.1

Added beta release of Bats of the Neotropics classifiers

Use new directory browsing control on batch panel

Analysis window cursor now displays mean and cumulative dB power spectrum

Analysis window you can now left-click copy to copy raw data to the clipboard and then paste it to a spreadsheet.

Fix problem related to viewing triggered WAC files

Fix problem playing back right channel of stereo recordings

Opening viewer no longer opens control panel window

Version 2.1.0

Improvements to Zero Crossing Extraction from Full Spectrum

Previous versions excluded the first and last "dot" in the sequence of smooth dots forming a call. This change improves zero crossing extraction, call detection and classification performance as a result. The new 2.1.0 classifiers are tuned to work with this change.

Fix detection and classification of low frequency bats

Previous versions continued to filter frequencies below 16kHz for classification even though new low-frequency bats below 16kHz were introduced in the classifiers resulting in poor performance. This has now been corrected.

Change the regional buttons on the classifier page to a pull-down list

Now larger classifiers can be created with more regions e.g. U.S. states.

Add "Zoom to fit" for selection boxes

Now if you right click inside a selection box within the spectrogram or waveform view, a pop-up menu appears. Right now the only choice is to "Zoom to fit" which will expand the selected region to fill the corresponding windows.

Fix "About" page on classifier tab

This was broken on a previous release and now fixed.

Version 2.0.7

Fix handling of GPS output on stereo recordings

UK classifiers back to Myotis genus-level only and improved

Version 2.0.5

Minor improvements to classifiers

Fix crash on opening results window with non-ASCII characters in filenames

Version 2.0.4

Fix UK classifiers now at 2.0.3

Version 2.0.3

Another fix for UK-only license problem causing crash on launch

Version 2.0.2

Revision to UK classifiers to fix problems in training data

Fix spectrogram window focus handling

Version 2.0.1

Fix UK-only license problem preventing UK classifiers from being selected

Version 2.0.0

Add reference call cluster display in viewer (for new classifiers)

Support for improved classifiers at version 2.0.0

Support for playback of Echo Meter Touch voice notes

Support for Echo Meter Touch metadata including GPS

Improve filtering and signal detection algorithms

Improve time/date parsing in filenames with suffixes

Improve progress bar calculations

Improve compatibility with other recorders

Improve import and export of settings

Change filter defaults for low frequency bats

Fix occasional crash on launch

Fix occasional crash on processing incorrectly formatted wav files

Fix for Mac to open ZC files from file open dialog

Upgrade to wxWidgets-3.0.0

Version 1.1.22

Fix bug in zero cross conversion

High frequency noise was not being filtered out correctly.

Version 1.1.21

Add UK classifier version 1.0.5 with new PINA data

Version 1.1.20

Fix zero crossing conversion with split to max duration

Make zero crossing output noise filtering consistent with full spectrum during conversion

Version 1.1.19

Fix bug in KML GPS reporting when within one degree west of meridian

Version 1.1.18

Add noise and auto-id to GPS outputs

Version 1.1.17

Fix selection playback when box drawn backward (not actually fixed in 1.1.16)

Version 1.1.16

Fix memory corruption problem causing corrupted id results

Added support for UK only license

Version 1.1.15

Improve audio quality of sound playback

Add Linux support for sound playback

Allow spaces in species labels for user-defined buttons

Work around pre Wac2Wav 3.2.6 bug

Old versions of Wac2Wav created zero-crossing files with incorrectly formatted date information in the meta data which then confuses Kaleidoscope. Kaleidoscope now detects and corrects for this condition.

Version 1.1.13

Add sound playback at various speeds

The play button will start playing the displayed spectrogram or selection. Several playback speeds for faster/slower playback are available. The brightness control doubles as a volume control.

Add "Auto" choice in input wav time expansion choice

If the time expansion factor for input WAV files is set to "Auto", then the time expansion factor will be determined either first by meta data present in the file, or second by the sample rate with the assumption that files sampled at <= 96kHz are 10X time expansion while files > 96kHz are 1X time expansion.

Add support for parsing Sonobat comments and time expansion factor meta data in wav files

Fix bug where files shorter than 1.1 seconds were not being analyzed

Fix bug where read-only files fail to open.

Kaleidoscope Viewer attempted to open files as writable to update meta data. Now never opens "input files" as writable (e.g. when opened from results window with no output files present), and will open read-only files as read only.

Version 1.1.10

Performance improvement

Previous version changes to P-value calculation caused significant delays after scanning is completed before outputs are generated, especially when a large number of input folders was present.

Version 1.1.9

Improve calculation of P-Values with Maximum Likelihood Estimator

Fix bug in parsing filenames in second batch pass correcting handling of milliseconds and channel numbers. Previously it was possible in stereo recordings for one channel output to overwrite a file from another channel.

Version 1.1.8

Fix bug causing corrupt meta data in ZC file if blank manual id

Fix bug handling daily/nightly directories in viewer results

Version 1.1.7

Add time expansion control to viewer for convenience

Add spectrum analysis window

Performance improvements when displaying log amplitude

Fix bug causing long horseshoe bat vocalizations to be ignored

Fix bug causing crash on large files

Fix bug causing wrong meta data to be written to last files of batch

Fix bug preventing selection of external drive root as input directory.

Version 1.1.4

Fix bug causing occasional crash in viewer

Fix bug causing occasional crash when loading results csv

Work around problem with some badly formatted WAV files

Version 1.1.3

Fix bug causing possible corruption of input BatSound files

When opening a BatSound file in the viewer, the BatSound file header may become corrupted. If this has happened to you, please let us know at support2013@wildlifeacoustics.com so we can help restore your files.

Fix bug preventing the viewer from opening input files under folders

Version 1.1.2

Extend demo licenses to at least Jun 30, 2013

Version 1.1.1

Add support for Kaleidoscope Viewer

id.csv file now split with summary data in idsummary.csv and detail in id.csv. Columns in id.csv changed for easier manual verification with Kaleidoscope Viewer and pivot table generation. See help files for details.

Version 1.0.0

Initial production release

Wildlife Acoustics is proud to support wildlife conservation efforts

Merlin Tuttle's Bat Conservation Bat Conservation International Bat Conservation Trust Wildlife Habitat Counsil